summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristian Hesse2015-08-06 10:27:37 +0200
committerChristian Hesse2015-08-06 10:27:37 +0200
commit40415c4590a9b70cd10682e25d0e12895b648844 (patch)
tree309776d62479e58f792681c6acc83c640c6cb2b0 /PKGBUILD
downloadaur-40415c4590a9b70cd10682e25d0e12895b648844.tar.gz
initial import of zsh-git 5.0.8.r162.g2fc05d5-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD110
1 files changed, 110 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b85d93904e52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,110 @@
+# Maintainer: Christian Hesse <mail@eworm.de>
+# Contributor: Pierre Schmitz <pierre@archlinux.de>
+
+_pkgbase=zsh
+pkgbase=zsh-git
+pkgname=('zsh-git' 'zsh-doc-git')
+pkgver=5.0.8.r162.g2fc05d5
+pkgrel=1
+arch=('i686' 'x86_64')
+url='http://www.zsh.org/'
+license=('custom')
+makedepends=('git' 'yodl' 'texinfo' 'texlive-plainextra' 'pcre' 'libcap' 'gdbm')
+source=('zsh::git://git.code.sf.net/p/zsh/code'
+ 'zprofile')
+md5sums=('SKIP'
+ '24a9335edf77252a7b5f52e079f7aef7')
+
+pkgver() {
+ cd "${srcdir}/${_pkgbase}"
+
+ if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
+ printf '%s.r%s.g%s' \
+ "$(sed -e "s/^${pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
+ "$(git rev-list --count ${GITTAG}..)" \
+ "$(git log -1 --format='%h')"
+ else
+ printf '0.r%s.g%s' \
+ "$(git rev-list --count master)" \
+ "$(git log -1 --format='%h')"
+ fi
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgbase}"
+
+ # Set correct keymap path
+ sed -i 's#/usr/share/keymaps#/usr/share/kbd/keymaps#g' Completion/Unix/Command/_loadkeys
+
+ # Fix usb.ids path
+ sed -i 's#/usr/share/misc/usb.ids#/usr/share/hwdata/usb.ids#g' Completion/Linux/Command/_lsusb
+
+ # Remove unneeded and conflicting completion scripts
+ for _fpath in AIX BSD Cygwin Darwin Debian Mandriva openSUSE Redhat Solaris; do
+ rm -rf Completion/$_fpath
+ sed "s#\s*Completion/$_fpath/\*/\*##g" -i Src/Zle/complete.mdd
+ done
+ rm -f Completion/Linux/Command/_{pkgtool,rpmbuild,yast}
+ rm -f Completion/Unix/Command/_{osc,systemd}
+}
+
+build() {
+ cd "${srcdir}/${_pkgbase}"
+
+ ./Util/preconfig
+ ./configure --prefix=/usr \
+ --docdir=/usr/share/doc/zsh \
+ --htmldir=/usr/share/doc/zsh/html \
+ --enable-etcdir=/etc/zsh \
+ --enable-zshenv=/etc/zsh/zshenv \
+ --enable-zlogin=/etc/zsh/zlogin \
+ --enable-zlogout=/etc/zsh/zlogout \
+ --enable-zprofile=/etc/zsh/zprofile \
+ --enable-zshrc=/etc/zsh/zshrc \
+ --enable-maildir-support \
+ --with-term-lib='ncursesw' \
+ --enable-multibyte \
+ --enable-function-subdirs \
+ --enable-fndir=/usr/share/zsh/functions \
+ --enable-scriptdir=/usr/share/zsh/scripts \
+ --with-tcsetpgrp \
+ --enable-pcre \
+ --enable-cap \
+ --enable-zsh-secure-free
+ make
+
+ cd "${srcdir}/${_pkgbase}/Doc"
+
+ make zsh.pdf
+}
+
+check() {
+ cd "${srcdir}/${_pkgbase}"
+ HOME="${srcdir}" make check
+}
+
+package_zsh-git() {
+ pkgdesc='A very advanced and programmable command interpreter (shell) for UNIX'
+ depends=('pcre' 'libcap' 'gdbm')
+ conflicts=('zsh')
+ provides=('zsh')
+ backup=('etc/zsh/zprofile')
+ install=zsh.install
+
+ cd "${srcdir}/${_pkgbase}"
+ make DESTDIR="${pkgdir}/" install
+ install -D -m644 "${srcdir}/zprofile" "${pkgdir}/etc/zsh/zprofile"
+ install -D -m644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+package_zsh-doc-git() {
+ pkgdesc='Info, HTML and PDF format of the ZSH documentation'
+ conflicts=('zsh-doc')
+ provides=('zsh-doc')
+ install=zsh-doc.install
+
+ cd "${srcdir}/${_pkgbase}"
+ make DESTDIR="${pkgdir}/" install.info install.html
+ install -D -m644 Doc/zsh.pdf "${pkgdir}/usr/share/doc/zsh/zsh.pdf"
+ install -D -m644 LICENCE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}