summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJakob Helmecke2022-02-20 20:38:10 +0100
committerJakob Helmecke2022-02-20 20:38:10 +0100
commit3663ad11bb02fd23bab647bce6c5e1f873090f21 (patch)
treeaa723270594b7d1ed8175efbd1da7e7318a4591d /PKGBUILD
downloadaur-3663ad11bb02fd23bab647bce6c5e1f873090f21.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b7774fd98a78
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jakob Helmecke <j dot helmecke at gmail dot com>
+
+pkgname=zsh-hist-git
+_pkgname=${pkgname::-4}
+pkgver=r55.42cd5c2
+pkgrel=1
+pkgdesc="Edit your Zsh history, without ever leaving the command line."
+arch=('any')
+url="https://github.com/marlonrichert/zsh-hist.git"
+license=('MIT')
+depends=('zsh')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+https://github.com/marlonrichert/zsh-hist.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd zsh-hist
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd zsh-hist
+ install -vDm 644 ${_pkgname}.plugin.zsh \
+ -t "${pkgdir}/usr/share/zsh/plugins/${_pkgname}/"
+ # docs
+ install -vDm 644 README.md \
+ -t "${pkgdir}/usr/share/doc/${_pkgname}/"
+ # license
+ install -vDm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}/"
+}