summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrafaelrc72022-01-23 18:43:47 -0300
committerrafaelrc72022-01-23 18:43:47 -0300
commit5c889b5964c85ce129ad2c6939b34a732c16c91b (patch)
tree5104c2840a45b00b3b5b2090061546c53ed26e9c /PKGBUILD
downloadaur-5c889b5964c85ce129ad2c6939b34a732c16c91b.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0e233b88c08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Rafael <rafaelrc7@gmail.com>
+
+_pkgname=zsh-nix-shell
+pkgname="${_pkgname}-git"
+pkgver=v0.4.0.r1.gf8574f2
+pkgrel=1
+pkgdesc="zsh plugin that lets you use zsh in nix-shell shells."
+arch=('any')
+url="https://github.com/chisui/zsh-nix-shell"
+license=('BSD')
+depends=('zsh')
+makedepends=('git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("git+${url}#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ install -Dm644 nix-shell.plugin.zsh \
+ "${pkgdir}/usr/share/zsh/plugins/${_pkgname}/nix-shell.plugin.zsh"
+ install -Dm755 "./scripts/buildShellShim" \
+ "${pkgdir}/usr/share/zsh/plugins/${_pkgname}/scripts/buildShellShim"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+