summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHalosGhost2015-06-26 22:38:31 -0500
committerHalosGhost2015-06-26 22:38:31 -0500
commitddbb716a84d795d5d62632ec4841c0ffe89e52b3 (patch)
tree683581d68bd407c9ab30c5e4b630bf4860b863c1 /PKGBUILD
downloadaur-ddbb716a84d795d5d62632ec4841c0ffe89e52b3.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcbdb03ce6a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sam Stuewe <halosghost at archlinux dot info>
+# Contributor: mjheagle <mjheagle8@gmail.com>
+_name='zsh-syntax-highlighting'
+pkgname="${_name}-git"
+pkgver=0.2.1.228.3dc5741
+pkgrel=1
+pkgdesc='Fish shell like syntax highlighting for Zsh'
+url='https://github.com/zsh-users/zsh-syntax-highlighting'
+arch=('any')
+license=('Custom')
+depends=('zsh>=4.3.9')
+makedepends=('git')
+install="${_name}.install"
+source=("${_name}::${url//https/git}")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ echo "0.2.1.$(git rev-list --count HEAD).$(git describe --always )"
+}
+
+package() {
+ cd "${srcdir}/${_name}"
+ install -d "${pkgdir}/usr/share/zsh/plugins/${_name}"
+ cp -a --no-preserve=ownership * "${pkgdir}/usr/share/zsh/plugins/${_name}"
+}