summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMonstrousOgre2021-02-14 18:28:23 +0530
committerMonstrousOgre2021-02-14 18:28:23 +0530
commitc5753b03675e99747e2c3f931694c711fe0a782a (patch)
tree941e98fd7910afbd9bcb0393f4c3689ec5f3b761 /PKGBUILD
downloadaur-c5753b03675e99747e2c3f931694c711fe0a782a.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5c94dded8547
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: MonstrousOgre <monstrousogre0813@gmail.com>
+
+_pkgname=zsh-vi-mode
+pkgname=zsh-vi-mode-git
+pkgver=0.6.0.r26.g20c7e76
+pkgrel=1
+pkgdesc="A better and friendly vi(vim) mode plugin for ZSH"
+arch=('any')
+url="https://github.com/jeffreytse/zsh-vi-mode"
+license=('MIT')
+depends=('zsh')
+makedepends=('git')
+provides=('zsh-vi-mode')
+conflicts=('zsh-vi-mode')
+source=("git+$url")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$_pkgname/"
+
+ install -Dm644 zsh-vi-mode.plugin.zsh "${pkgdir}/usr/share/zsh/plugins/$_pkgname/zsh-vi-mode.plugin.zsh"
+ install -Dm644 zsh-vi-mode.zsh "${pkgdir}/usr/share/zsh/plugins/$_pkgname/zsh-vi-mode.zsh"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}