summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSumner Evans2018-04-01 19:51:00 -0600
committerSumner Evans2018-04-01 19:51:00 -0600
commit6812710a8aa1ab97a55fc7cb32caec76c436ce21 (patch)
tree9e88abe19f2964b0bfe8cf3b6999c7560ba7870a /PKGBUILD
downloadaur-6812710a8aa1ab97a55fc7cb32caec76c436ce21.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f97fbda85ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jonathan Sumner Evans <sumner.evans98@gmail.com>
+
+pkgname="zsh-you-should-use"
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="ZSH plugin that reminds you to use existing aliases for commands you just typed"
+url="https://github.com/MichaelAquilina/zsh-you-should-use"
+arch=("any")
+license=("MIT")
+source=("https://github.com/MichaelAquilina/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=("7af71b463d998fa2388a4dd52ea75ce9ee1568cf233c8b2e41b690b04e250b40")
+
+package() {
+ install -d "${pkgdir}/usr/share/zsh/plugins/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/you-should-use.plugin.zsh" \
+ "${pkgdir}/usr/share/zsh/plugins/${pkgname}"
+
+ # License
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+post_install() {
+ cat << EOF
+To activate zsh-you-should-use add the following line at the end of ~/.zshrc:
+ source /usr/share/zsh/plugins/zsh-you-should-use/you-should-use.plugin.zsh
+EOF
+}