summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2017-07-31 11:13:48 -0400
committerGuillaume Horel2017-07-31 11:13:48 -0400
commit9e7eb17c561aae04f3edb7a1cb37042e948d58bc (patch)
tree9d0bcaa6b825c41be72b8f98ff51af2905913384 /PKGBUILD
downloadaur-9e7eb17c561aae04f3edb7a1cb37042e948d58bc.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b45ee3f84b7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+# Contributor: Andrzej Giniewicz <gginiu@gmail.com>
+# Contributor: Johan Förberg <johan@forberg.se>
+
+pkgname=zstd-static
+_pkgname=${pkgname%-static}
+pkgver=1.3.0
+pkgrel=1
+pkgdesc='Zstandard - Fast real-time compression algorithm'
+arch=('i686' 'x86_64')
+url='http://www.zstd.net/'
+license=('BSD')
+depends=('zlib' 'xz')
+makedepends=('gtest')
+options=('staticlibs')
+source=("https://github.com/facebook/zstd/archive/v${pkgver}.tar.gz")
+sha1sums=('1b254a1a7092886c7e17957b5f672b8c1b972b08')
+provides=('zstd')
+conflicts=('zstd')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make CFLAGS="$CFLAGS -fPIC"
+ make zstdmt
+ make -C contrib/pzstd
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ make PREFIX="/usr" DESTDIR="$pkgdir/" install
+ install -D -m755 zstdmt "$pkgdir/usr/bin/zstdmt"
+ install -D -m755 contrib/pzstd/pzstd "$pkgdir/usr/bin/pzstd"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 PATENTS "$pkgdir/usr/share/licenses/$pkgname/PATENTS"
+}