summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-02-10 11:38:11 -0700
committerMark Wagie2022-02-10 11:38:11 -0700
commit1a930a129f030e5b05fa4923578560e10fc7f51e (patch)
treef3a90287400e080d2a419b36e7c0d2c6e51baf90 /PKGBUILD
parent6fa99de0bb9b22709e65ae228fa0b1f6624d9d64 (diff)
downloadaur-1a930a129f030e5b05fa4923578560e10fc7f51e.tar.gz
5.8.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD71
1 files changed, 37 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eef8a3f43184..fbae8386cafa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,49 @@
-# Maintainer: aspen <aspen@aspenuwu.me>
-# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
-# Maintainer: Jean Lucas <jean@4ray.co>
-# Maintainer: AI5C <ai5c@ai5c.com>
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: aspen <aspen@aspenuwu.me>
+# Contributor: Eric Engestrom <aur [at] engestrom [dot] ch>
+# Contributor: Jean Lucas <jean@4ray.co>
+# Contributor: AI5C <ai5c@ai5c.com>
# Contributor: kaptoxic <kaptoxic at yahoo dot com>
# Contributor: Matthew Avant <matthew dot avant at gmail dot com>
# Contributor: Rose Ames <rose at happyspork dot com>
-_pkgbase=zulip-desktop
-pkgname=$_pkgbase-electron
-pkgver=5.5.0
+pkgname=zulip-desktop-electron
+pkgver=5.8.1
pkgrel=1
-pkgdesc='Real-time team chat based on the email threading model, using system electron'
-arch=(i686 x86_64)
-url=https://zulipchat.com
-license=(Apache)
-depends=(libxkbfile gtk3 libxss nss electron)
-makedepends=(npm python2)
-provides=($_pkgbase)
-conflicts=($_pkgbase)
-source=($_pkgbase-$pkgver.tar.gz::https://github.com/zulip/$_pkgbase/archive/v$pkgver.tar.gz
- $_pkgbase.desktop)
-sha512sums=('d3a73896b97b9e0353f168e3b5d98ef6d5f5dc8bdeb6314a832a8664f01b5aa62e802ff883647a7379b1671ce1bb0404256771ed3c84590d2fcf83349d62fa06'
- '51708745a8e8e09a5ac949c6f4814e86118008c07c3b03d84559468dcaef880431f401ab06bd552b32376d93831a14b6b9337c66dfe23531016266a155f22aa3')
+_electronversion=13
+pkgdesc='Real-time team chat based on the email threading model'
+arch=('x86_64')
+url="https://zulip.com"
+license=('Apache')
+depends=("electron$_electronversion" 'libxkbfile' 'libxss')
+makedepends=('nodejs>=12.10.0' 'npm')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=("${pkgname%-*}-$pkgver.tar.gz::https://github.com/zulip/zulip-desktop/archive/v$pkgver.tar.gz"
+ "${pkgname%-*}.desktop"
+ "${pkgname%-*}.sh")
+sha256sums=('870a3ccbae76ee8dba53b30cd00edc16e68fc2822a1d2dca0d955f6648353e7c'
+ '5d7a8831cdef6686339bc6581ed750d90f804e5fb0bebe897feed0b8eefba702'
+ 'e03dbea7a85783012a59bdfe476ee4777c9970973f8f166e7596d613129b3d82')
build() {
- cd $_pkgbase-$pkgver
- npm i
- npm run pack
+ cd "${pkgname%-*}-$pkgver"
+ electronDist="/usr/lib/electron$_electronversion"
+ electronVer="$(sed s/^v// /usr/lib/electron$_electronversion/version)"
+ HOME="$srcdir/.electron-gyp" npm install --cache "$srcdir/npm-cache"
+ ./node_modules/.bin/tsc
+ ./node_modules/.bin/electron-builder --linux --x64 --dir \
+ $dist -c.electronDist=$electronDist -c.electronVersion=$electronVer
}
package() {
- cd $_pkgbase-$pkgver
+ cd "${pkgname%-*}-$pkgver"
+ install -Dm644 dist/linux-unpacked/resources/app.asar -t "$pkgdir/usr/lib/${pkgname%-*}/resources/"
+ install -Dm755 "$srcdir/${pkgname%-*}.sh" "$pkgdir/usr/bin/zulip"
+ install -Dm644 "$srcdir/${pkgname%-*}.desktop" -t "$pkgdir/usr/share/applications/"
- install -d "$pkgdir"/usr/{lib,bin}
- cp -a dist/linux-unpacked "$pkgdir"/usr/lib/$_pkgbase
- ln -s /usr/lib/$_pkgbase/zulip "$pkgdir"/usr/bin
-
- install -Dm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$_pkgbase
-
- install -Dm 644 ../$_pkgbase.desktop -t "$pkgdir"/usr/share/applications
- for i in 16 24 32 48 64 96 128 256 512; do
- install -Dm 644 build/icons/${i}x${i}.png \
- "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/zulip.png
- done
+ for i in 16 24 32 48 64 96 128 256 512 1024; do
+ install -Dm644 build/icons/${i}x${i}.png \
+ "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/zulip.png"
+ done
}