summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHong Shick Pak2021-04-11 13:52:55 -0700
committerHong Shick Pak2021-04-11 13:52:55 -0700
commit27ad16b904d41776c2619168e1b0dcd948857e05 (patch)
treed71162497832327c2ddbf12ae9d2d4e1d078b8d4 /PKGBUILD
parentadad04e1e01708ca671e6ced4c65165bd69e4159 (diff)
downloadaur-27ad16b904d41776c2619168e1b0dcd948857e05.tar.gz
fix git version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 22e9cf18b8ef..3d0cee1bca5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Hong Shick Pak <hong@hspak.com>
pkgname=zur-git
-pkgver=0.5
+pkgver=0.5.0+3+g49035b5
pkgrel=1
pkgdesc="An AUR helper written in Zig"
arch=("x86_64")
@@ -14,6 +14,11 @@ conflicts=("$pkgname")
source=("git+https://github.com/hspak/zur")
sha256sums=("SKIP")
+pkgver() {
+ cd "$(echo $pkgname | cut -d'-' -f1)"
+ git describe --tags | sed 's/-/+/g'
+}
+
build() {
cd "$(echo $pkgname | cut -d'-' -f1)"
zig build -Dversion="${pkgver}" -Drelease-safe=true