summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHong Shick Pak2021-04-10 22:17:23 -0700
committerHong Shick Pak2021-04-10 22:17:23 -0700
commitadad04e1e01708ca671e6ced4c65165bd69e4159 (patch)
tree7a4e7f991df096104060025284a739cd5f1a19a1 /PKGBUILD
downloadaur-adad04e1e01708ca671e6ced4c65165bd69e4159.tar.gz
publish 0.5.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22e9cf18b8ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Hong Shick Pak <hong@hspak.com>
+
+pkgname=zur-git
+pkgver=0.5
+pkgrel=1
+pkgdesc="An AUR helper written in Zig"
+arch=("x86_64")
+url="https://github.com/hspak/zur"
+license=("MIT")
+depends=("pacman" "curl")
+makedepends=("zig-git" "git")
+provides=("$pkgname")
+conflicts=("$pkgname")
+source=("git+https://github.com/hspak/zur")
+sha256sums=("SKIP")
+
+build() {
+ cd "$(echo $pkgname | cut -d'-' -f1)"
+ zig build -Dversion="${pkgver}" -Drelease-safe=true
+}
+
+check() {
+ cd "$(echo $pkgname | cut -d'-' -f1)"
+ zig-cache/bin/zur --version
+}
+
+package() {
+ cd "$(echo $pkgname | cut -d'-' -f1)"
+ install -D -m 0755 "zig-cache/bin/zur" "${pkgdir}/usr/bin/zur"
+ install -D -m 0644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ft=sh syn=sh et