summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYurenev Nikolay2022-12-02 19:49:06 +0200
committerYurenev Nikolay2022-12-02 19:49:06 +0200
commit51edabb1c24d589dcb9b2ded094e42355330a522 (patch)
tree1bf843dc7eaca6a0747add6e4e34af3e9ba3f602 /PKGBUILD
downloadaur-51edabb1c24d589dcb9b2ded094e42355330a522.tar.gz
pushing ZVM to AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fedbcb65b530
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Yurenev Nikolay <yurnik2004 at gmail.com>
+
+pkgname='zvm'
+pkgver='0.0.1_alpha'
+pkgrel='1'
+arch=('x86_64')
+license=('MIT')
+makedepnds=()
+source=(
+ "$pkgname-$pkgver.tar.gz::https://github.com/tristanisham/zvm/archive/refs/tags/v0.0.1-alpha.tar.gz"
+ 'https://ziglang.org/download/0.10.0/zig-linux-x86_64-0.10.0.tar.xz'
+)
+md5sums=(
+ 'fef62bef20d0dbc1b090156d8ff62369'
+ 'a73088e3806e4973f241665f73f23376'
+)
+
+build() {
+ cd zvm-0.0.1-alpha
+ ../zig-linux-x86_64-0.10.0/zig build
+}
+
+package() {
+ cd zvm-0.0.1-alpha
+ mkdir -p "$pkgdir/usr/bin"
+ cp zig-out/bin/zvm "$pkgdir/usr/bin"
+}