summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYurii Kolesnykov2018-12-01 15:44:25 +0100
committerYurii Kolesnykov2018-12-01 15:44:25 +0100
commitedd0eddaada6e58f9329ff2290fd93f3e37fa05d (patch)
treeb7fd741fef0a8d956a0d04161a75dc3b53a7ffdc /PKGBUILD
downloadaur-edd0eddaada6e58f9329ff2290fd93f3e37fa05d.tar.gz
init, 1.14.17
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84c8b24d057f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Yurii Kolesnykov <root@yurikoles.com>
+
+pkgname=zypper
+pkgver=1.14.17
+pkgrel=1
+pkgdesc="Command line software manager using libzypp"
+arch=('i686' 'x86_64')
+url="https://github.com/openSUSE/zypper"
+license=('GPL')
+depends=('libzypp' 'libxml2' 'procps' 'readline' 'augeas')
+makedepends=('git' 'cmake' 'boost' 'asciidoc')
+provides=('zypper' 'apt')
+conflicts=('apt')
+source=("https://github.com/openSUSE/zypper/archive/${pkgver}.tar.gz"
+ 'make-ZyppCommon-cmake-module-includable.patch')
+sha256sums=('9a1f74b4700e5bc547c22eb9351fb09017f9153ce987084f4664bface096e844'
+ 'f5cdd85109c58d786f1124fa3cab1c5431a93a8d87a59117eac257c6e4698ae7')
+
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 -i $srcdir/make-ZyppCommon-cmake-module-includable.patch
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cmake -D CMAKE_INSTALL_PREFIX=/usr \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D LIB=/lib \
+ -D ZYPP_PREFIX=/usr \
+ .
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir/" install
+
+ # hacky sbin symlink fix
+ mv $pkgdir/usr/sbin/* $pkgdir/usr/bin/
+ rmdir $pkgdir/usr/sbin
+}