aboutsummarylogtreecommitdiffstats
path: root/README.md
diff options
context:
space:
mode:
authorErik Bjäreholt2023-10-25 11:53:19 +0200
committerErik Bjäreholt2023-10-25 11:53:40 +0200
commit5567b12e274ccfef780f03750abbbc483827c276 (patch)
tree72505e60e7fb675e959012f98a4b7897f1d73e74 /README.md
parent6ebb975497048f48a4c180991db656fa1cbdc4c2 (diff)
downloadaur-5567b12e274ccfef780f03750abbbc483827c276.tar.gz
added computing md5sums with updpkgsums (fixes https://github.com/ActivityWatch/aur-activitywatch-bin/issues/9)
Co-authored-by: Asuka Minato <i@asukaminato.eu.org>
Diffstat (limited to 'README.md')
-rw-r--r--README.md12
1 files changed, 8 insertions, 4 deletions
diff --git a/README.md b/README.md
index e90a2bbdaef9..7607d44ed6c8 100644
--- a/README.md
+++ b/README.md
@@ -10,11 +10,15 @@ You need:
- Maintainer rights to the AUR package
- Your AUR ssh key configured
-After checking that the package builds correctly (using `make package`) simply run:
-
+After modifying `PKGBUILD` as appropriate, and testing the package on your machine, run the following to:
+ - build the package
+ - updates checksums with `updpkgsums`
+ - regenerates `.SRCINFO` with `makepkg --printsrcinfo > .SRCINFO`
+ - commit the changes
+ - push to the AUR
```sh
-make srcinfo
-git add srcinfo
+make package
+git add PKGBUILD .SRCINFO
git commit -m "Updated .SRCINFO"
git remote add aur aur@aur.archlinux.org/activitywatch-bin.git
git push aur