aboutsummarylogtreecommitdiffstats
path: root/README.md
diff options
context:
space:
mode:
authorJoe Previte2021-03-08 21:04:00 +0000
committerJoe Previte2021-03-08 21:04:00 +0000
commit9abfacaa2af6c798a63390284a3c69db8542f41f (patch)
tree509e3cf90965aaf3a5e21a5367365bd01812ea20 /README.md
parent138b11ad8f6e292a57bbd73d80cc9c81aeeb2b40 (diff)
downloadaur-9abfacaa2af6c798a63390284a3c69db8542f41f.tar.gz
docs: refactor updating instructions
Diffstat (limited to 'README.md')
-rw-r--r--README.md31
1 files changed, 10 insertions, 21 deletions
diff --git a/README.md b/README.md
index 1464f0e8db8a..ce4e76d9b655 100644
--- a/README.md
+++ b/README.md
@@ -7,28 +7,17 @@ Previously maintained by [KSXGitHub](https://github.com/KSXGitHub)
## Updating
-If there are no breaking changes with the release, updating the package is as
-simple as updating `pkgver` in `PKGBUILD` to the new version. Make sure
-to run `updpkgsums` to update the sha256 sums.
-
-After updating, run this command on an Arch machine to update the `.SRCINFO`.
-This is the file that is used by the AUR to show package info.
+Make sure you run these commands on an Arch machine. If you're a Coder employee, we suggest using your dogfooding environment.
+1. Update the `pkgver` in `PKGBUILD` to the latest version
+1. Run `updpkgsums` to update the sha256 sums
+ - If you don't have it installed, run `sudo pacman -S pacman-contrib`
+1. Update the `.SRCINFO` by running:
```bash
+# This is the file that is used by the AUR to show package info.
makepkg --printsrcinfo > .SRCINFO
```
-
-Then, just push to the AUR git repo. You'll have to maintain two remotes in
-your `.git/config`. Mine is setup as so
-
-```
-[remote "origin"]
- url = git@github.com:/cdr/code-server-aur.git
- fetch = +refs/heads/*:refs/remotes/origin/*
-[remote "aur"]
- url = ssh://aur@aur.archlinux.org/code-server.git
- fetch = +refs/heads/*:refs/remotes/aur/*
-```
-
-Then it's as simple as `git push` to push to GitHub and `git push aur` to
-update the AUR.
+1. Push changes to GitHub
+1. Push changes to `aur`
+ - If you don't have this set up, run `git remote add aur ssh://aur@aur.archlinux.org/code-server.git`
+ - Run `git push aur`