aboutsummarylogtreecommitdiffstats
path: root/README.md
diff options
context:
space:
mode:
authorJoe Previte2021-03-08 21:51:28 +0000
committerJoe Previte2021-03-08 21:51:28 +0000
commitac982de112e2d1d867d0020c73c5db7a77c7c40f (patch)
treef616c515ceb713cb6b90634c862bc1fc9b36ea11 /README.md
parente78b62ecefb1e93f6e74994042ba9c7d3154578c (diff)
downloadaur-ac982de112e2d1d867d0020c73c5db7a77c7c40f.tar.gz
docs: add ssh information
Diffstat (limited to 'README.md')
-rw-r--r--README.md21
1 files changed, 20 insertions, 1 deletions
diff --git a/README.md b/README.md
index 724125f7b08b..56f5a17759b5 100644
--- a/README.md
+++ b/README.md
@@ -22,9 +22,28 @@ makepkg --printsrcinfo > .SRCINFO
- If you don't have this set up, run `git remote add aur ssh://aur@aur.archlinux.org/code-server.git`
- Run `git push aur`
+### SSH Key
+
+In order to publish updates to AUR, you'll need to have an SSH key pair setup.
+
+1. Create a config file file `~/.ssh/config`
+```text
+Host aur.archlinux.org
+ IdentityFile ~/.ssh/aur
+ User aur
+```
+2. Create a new key pair by running:
+```shell
+ssh-keygen -f ~/.ssh/aur
+```
+3. This will create a new public key at `.ssh/aur.pub`. Copy this and add to your AUR account under [My Account](https://aur.archlinux.org/account/yourusername/edit/) > SSH Public Key
+4. You may also need to be added by the package maintainer (@coadler)
+
+Read more: https://wiki.archlinux.org/index.php/AUR_submission_guidelines
+
### New Maintainers
-If a new maintainer joins the project, please add them to the top of `PKGBUILD`
+If a new maintainer joins the project, please add them to the top of `PKGBUILD`.
### Removing Old Maintainers