aboutsummarylogtreecommitdiffstats
path: root/README.md
diff options
context:
space:
mode:
authoryar2017-04-04 10:35:32 -0700
committeryar2017-04-04 11:59:12 -0700
commit622a4f60b2af0cbe663791b921166f1740d6abda (patch)
tree00b9f1f777eb3a5a7797a61ae12a7f219aea4fda /README.md
parentdd9dbe43a35f665b10ab779a5df0bcc43b5ecd65 (diff)
downloadaur-622a4f60b2af0cbe663791b921166f1740d6abda.tar.gz
target sandybridge CPUS and explain in README
Diffstat (limited to 'README.md')
-rw-r--r--README.md11
1 files changed, 11 insertions, 0 deletions
diff --git a/README.md b/README.md
index 1327b2e4228a..2449d3b2e3a8 100644
--- a/README.md
+++ b/README.md
@@ -32,6 +32,17 @@ Configs are a compromise between vanilla Linode and Arch. Most drivers are disab
Take extra care to make sure you're booting from the correct device name. Xen devices are called /dev/xvda while KVM devices are called /dev/sda. If you're running grub inside your old Xen linode, it will automatically add "root=/dev/xvda" to your kernel line in /boot/grub/grub.cfg. Once you migrate to KVM, this will no longer work. You'll have to either edit this file by hand before shutting down to migrate, or edit it using the interactive grub command line afterwards. Once you've migrated, running grub-mkconfig again should fix it. Also be sure to check /etc/fstab or /etc/crypttab for any other device names that might give you boot problems.
+# CPU ARCHITECTURE
+
+By default, the kernel is compiled with `-march=sandybridge -mtune=sandybridge`. This seems to be most common in my (limited) experience, but some linodes may have haswell, corei7 or other CPUs, in which case you can edit CFLAGS and CXXFLAGS in the PKGBUILD. To find yours:
+
+```
+$ gcc -c -Q -march=native --help=target 2>&1 | grep -e march -e mtune
+-march= sandybridge
+-mtune-ctrl=
+-mtune= sandybridge
+```
+
# STEPS TO USE
1. pacman -Syu