summarylogtreecommitdiffstats
path: root/Wno-restrict.patch
diff options
context:
space:
mode:
authorZiusudra2022-07-29 23:11:29 -0600
committerZiusudra2022-07-29 23:11:29 -0600
commit58aa9772144731523678bf204cf8cab2bc6b266b (patch)
tree853dcb5094f6692e75550e5f51ede11f4309c494 /Wno-restrict.patch
parentfef6cb0a7758be38961bb3dfa3848c6b1694a282 (diff)
downloadaur-58aa9772144731523678bf204cf8cab2bc6b266b.tar.gz
dfhack-0.47.05-r6 +patches
Diffstat (limited to 'Wno-restrict.patch')
-rw-r--r--Wno-restrict.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/Wno-restrict.patch b/Wno-restrict.patch
new file mode 100644
index 000000000000..8b43305f7d3e
--- /dev/null
+++ b/Wno-restrict.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text dfhack/CMakeLists.txt dfhack.new/CMakeLists.txt
+--- dfhack/CMakeLists.txt 2022-07-29 03:02:00.924080839 -0600
++++ dfhack.new/CMakeLists.txt 2022-07-29 03:43:33.584455373 -0600
+@@ -244,7 +244,7 @@
+ # enable C++11 features
+ add_definitions(-DLINUX_BUILD)
+ add_definitions(-D_GLIBCXX_USE_C99)
+- set(GCC_COMMON_FLAGS "-fvisibility=hidden -mtune=generic -Wall -Werror")
++ set(GCC_COMMON_FLAGS "-fvisibility=hidden -mtune=generic -Wall -Werror -Wno-restrict")
+ set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "${CMAKE_CXX_FLAGS_RELWITHDEBINFO} -g")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${GCC_COMMON_FLAGS}")
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${GCC_COMMON_FLAGS}")