aboutsummarylogtreecommitdiffstats
path: root/add-acs-overrides.patch
diff options
context:
space:
mode:
authorKatelyn Schiesser2020-02-15 19:17:31 -0800
committerKatelyn Schiesser2020-02-16 14:42:33 -0800
commitefbfaead51823102c32378484fc9cf65aea7708a (patch)
treecc1648d50beadd65a99691c1aea9cdb9a10dabb5 /add-acs-overrides.patch
parent1ec4cb0753488353e111496a90bdfbe2a074827e (diff)
downloadaur-efbfaead51823102c32378484fc9cf65aea7708a.tar.gz
Update to 5.5.3.arch1-1: i915 patch rewrite for new intel_vga, acs patch rebase, PKGBUILD changes to match upstream
Diffstat (limited to 'add-acs-overrides.patch')
-rw-r--r--add-acs-overrides.patch18
1 files changed, 9 insertions, 9 deletions
diff --git a/add-acs-overrides.patch b/add-acs-overrides.patch
index aa9b381f6d30..45e07018d166 100644
--- a/add-acs-overrides.patch
+++ b/add-acs-overrides.patch
@@ -53,7 +53,7 @@ diff --git a/Documentation/admin-guide/kernel-parameters.txt b/Documentation/adm
index 0c404cda531a..0d45f0014f4a 100644
--- a/Documentation/admin-guide/kernel-parameters.txt
+++ b/Documentation/admin-guide/kernel-parameters.txt
-@@ -3165,6 +3165,14 @@
+@@ -3423,6 +3423,14 @@
nomsi [MSI] If the PCI_MSI kernel config parameter is
enabled, this kernel boot option can be used to
disable the use of MSI interrupts system-wide.
@@ -69,10 +69,10 @@ index 0c404cda531a..0d45f0014f4a 100644
Safety option to keep boot IRQs enabled. This
should never be necessary.
diff --git a/drivers/pci/quirks.c b/drivers/pci/quirks.c
-index c0673a717239..695d99b390f7 100644
+index fbeb9f73ef28..3bf409c65609 100644
--- a/drivers/pci/quirks.c
+++ b/drivers/pci/quirks.c
-@@ -194,6 +194,106 @@ static int __init pci_apply_final_quirks(void)
+@@ -192,6 +192,106 @@ static int __init pci_apply_final_quirks(void)
}
fs_initcall_sync(pci_apply_final_quirks);
@@ -179,15 +179,15 @@ index c0673a717239..695d99b390f7 100644
/*
* Decoding should be disabled for a PCI device during BAR sizing to avoid
* conflict. But doing so may cause problems on host bridge and perhaps other
-@@ -4513,6 +4613,8 @@ static const struct pci_dev_acs_enabled {
- { PCI_VENDOR_ID_AMPERE, 0xE00A, pci_quirk_xgene_acs },
- { PCI_VENDOR_ID_AMPERE, 0xE00B, pci_quirk_xgene_acs },
- { PCI_VENDOR_ID_AMPERE, 0xE00C, pci_quirk_xgene_acs },
+@@ -4711,6 +4811,8 @@ static const struct pci_dev_acs_enabled {
+ { PCI_VENDOR_ID_BROADCOM, 0xD714, pci_quirk_brcm_acs },
+ /* Amazon Annapurna Labs */
+ { PCI_VENDOR_ID_AMAZON_ANNAPURNA_LABS, 0x0031, pci_quirk_al_acs },
+ /* allow acs for any */
+ { PCI_ANY_ID, PCI_ANY_ID, pcie_acs_overrides },
{ 0 }
};
---
-2.20.0
+--
+2.21.0