summarylogtreecommitdiffstats
path: root/adesklets.install
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commitda99aaab4d18a34a610e47560ba0c4a7d4f782d6 (patch)
tree15ef13db92bbc61543fb069fab009921f7a31936 /adesklets.install
downloadaur-da99aaab4d18a34a610e47560ba0c4a7d4f782d6.tar.gz
Initial PKGBUILD status as of 28.11.2014
Diffstat (limited to 'adesklets.install')
-rw-r--r--adesklets.install31
1 files changed, 31 insertions, 0 deletions
diff --git a/adesklets.install b/adesklets.install
new file mode 100644
index 000000000000..cae17e4998ba
--- /dev/null
+++ b/adesklets.install
@@ -0,0 +1,31 @@
+infodir=/usr/share/info
+filelist=(adesklets.info adesklets_fr.info)
+
+post_install() {
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+
+ getent group adesklets > /dev/null || usr/sbin/groupadd -g 107 adesklets
+cat << EOF
+
+==> To be able to save configs of adesklets
+==> add your user to the adesklets group:
+==> # gpasswd -a USERNAME adesklets
+
+EOF
+}
+
+post_upgrade() {
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file $infodir/dir 2> /dev/null
+ done
+}
+
+post_remove() {
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file $infodir/dir 2> /dev/null
+ done
+
+ usr/sbin/groupdel adesklets &>/dev/null
+}