summarylogtreecommitdiffstats
path: root/airsane-systemd-dir.patch
diff options
context:
space:
mode:
authorEric Anderson2020-12-19 13:52:34 -0800
committerEric Anderson2020-12-19 13:52:34 -0800
commitfdda27c45a919feaceabdaab300eae421f54fd79 (patch)
tree552a33009d1aa5ab9cdde216555d469d6d9a17c2 /airsane-systemd-dir.patch
downloadaur-fdda27c45a919feaceabdaab300eae421f54fd79.tar.gz
Initial commit
Diffstat (limited to 'airsane-systemd-dir.patch')
-rw-r--r--airsane-systemd-dir.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/airsane-systemd-dir.patch b/airsane-systemd-dir.patch
new file mode 100644
index 000000000000..d4b5bdd29a0b
--- /dev/null
+++ b/airsane-systemd-dir.patch
@@ -0,0 +1,31 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index f37e77d..13ab326 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -63,7 +63,7 @@ install(TARGETS ${PROJECT_NAME}
+ RUNTIME DESTINATION bin
+ )
+ install(FILES systemd/airsaned.service
+- DESTINATION /lib/systemd/system
++ DESTINATION /usr/lib/systemd/system
+ )
+ install(FILES systemd/airsaned.default
+ DESTINATION /etc/default
+diff --git a/systemd/airsaned.service b/systemd/airsaned.service
+index 2c17d67..a6a5134 100644
+--- a/systemd/airsaned.service
++++ b/systemd/airsaned.service
+@@ -4,10 +4,10 @@ After=network-online.target
+
+ [Service]
+ EnvironmentFile=-/etc/default/airsane
+-ExecStart=/usr/local/bin/airsaned --interface=${INTERFACE} --listen-port=${LISTEN_PORT} --access-log=${ACCESS_LOG} --hotplug=${HOTPLUG} --mdns-announce=${MDNS_ANNOUNCE} --local-scanners-only=${LOCAL_SCANNERS_ONLY} --options-file=${OPTIONS_FILE}
++ExecStart=/usr/bin/airsaned --interface=${INTERFACE} --listen-port=${LISTEN_PORT} --access-log=${ACCESS_LOG} --hotplug=${HOTPLUG} --mdns-announce=${MDNS_ANNOUNCE} --local-scanners-only=${LOCAL_SCANNERS_ONLY} --options-file=${OPTIONS_FILE}
+ ExecReload=/bin/kill -HUP $MAINPID
+-User=saned
+-Group=saned
++DynamicUser=true
++Group=scanner
+ Type=simple
+
+ [Install]