summarylogtreecommitdiffstats
path: root/apache-tools-Makefile.patch
diff options
context:
space:
mode:
authorGeorg Schlisio2015-07-07 23:01:44 +0200
committerGeorg Schlisio2015-07-07 23:01:44 +0200
commite7e57f65a1f68d08fa0283d7792a579049528391 (patch)
treeacb85b9a1edc950046b35e5eea8ba97617e70e79 /apache-tools-Makefile.patch
downloadaur-e7e57f65a1f68d08fa0283d7792a579049528391.tar.gz
2.4.12; moved from aur3
Diffstat (limited to 'apache-tools-Makefile.patch')
-rw-r--r--apache-tools-Makefile.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/apache-tools-Makefile.patch b/apache-tools-Makefile.patch
new file mode 100644
index 000000000000..c39ef55357d9
--- /dev/null
+++ b/apache-tools-Makefile.patch
@@ -0,0 +1,43 @@
+--- a/support/Makefile.in 2012-12-11 05:37:25.000000000 -0500
++++ b/support/Makefile.in 2013-03-26 23:16:05.982719344 -0400
+@@ -1,9 +1,9 @@
+ DISTCLEAN_TARGETS = apxs apachectl dbmmanage log_server_status \
+- logresolve.pl phf_abuse_log.cgi split-logfile envvars-std
++ logresolve.pl phf_abuse_log.cgi split-logfile
+
+ CLEAN_TARGETS = suexec
+
+-bin_PROGRAMS = htpasswd htdigest htdbm ab logresolve httxt2dbm
++bin_PROGRAMS = htpasswd htdigest htdbm ab logresolve httxt2dbm dbmmanage
+ sbin_PROGRAMS = htcacheclean rotatelogs $(NONPORTABLE_SUPPORT)
+ TARGETS = $(bin_PROGRAMS) $(sbin_PROGRAMS)
+
+@@ -15,26 +15,18 @@
+ install:
+ @test -d $(DESTDIR)$(bindir) || $(MKINSTALLDIRS) $(DESTDIR)$(bindir)
+ @test -d $(DESTDIR)$(sbindir) || $(MKINSTALLDIRS) $(DESTDIR)$(sbindir)
+- @test -d $(DESTDIR)$(libexecdir) || $(MKINSTALLDIRS) $(DESTDIR)$(libexecdir)
+- @cp -p $(top_builddir)/server/httpd.exp $(DESTDIR)$(libexecdir)
+- @for i in apxs dbmmanage; do \
++ @for i in $(bin_PROGRAMS); do \
+ if test -f "$(builddir)/$$i"; then \
+ cp -p $$i $(DESTDIR)$(bindir); \
+ chmod 755 $(DESTDIR)$(bindir)/$$i; \
+ fi ; \
+ done
+- @for i in apachectl; do \
++ @for i in $(sbin_PROGRAMS); do \
+ if test -f "$(builddir)/$$i"; then \
+ cp -p $$i $(DESTDIR)$(sbindir); \
+ chmod 755 $(DESTDIR)$(sbindir)/$$i; \
+ fi ; \
+ done
+- @if test -f "$(builddir)/envvars-std"; then \
+- cp -p envvars-std $(DESTDIR)$(sbindir); \
+- if test ! -f $(DESTDIR)$(sbindir)/envvars; then \
+- cp -p envvars-std $(DESTDIR)$(sbindir)/envvars ; \
+- fi ; \
+- fi
+
+ htpasswd.lo: passwd_common.h
+ passwd_common.lo: passwd_common.h