summarylogtreecommitdiffstats
path: root/arch-linux.patch
diff options
context:
space:
mode:
authorTony Lambiris2017-05-26 17:54:13 -0400
committerTony Lambiris2017-05-26 17:54:13 -0400
commit1868127e9b0ba702cd65ce28757dc6444b8b33db (patch)
tree659d55af3a7a1e3ffd1a7e5dbefd54b1d62e04fd /arch-linux.patch
parentb747b50690a4a43dd1cf93a75dcc35b6b446ce18 (diff)
downloadaur-1868127e9b0ba702cd65ce28757dc6444b8b33db.tar.gz
Version bump for osquery-git
Diffstat (limited to 'arch-linux.patch')
-rw-r--r--arch-linux.patch26
1 files changed, 13 insertions, 13 deletions
diff --git a/arch-linux.patch b/arch-linux.patch
index ca74540519fe..c226b0477930 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -81,19 +81,6 @@ index db05af9c..0b5c2291 100644
elseif(FREEBSD)
ADD_OSQUERY_LINK_CORE("icuuc")
ADD_OSQUERY_LINK_CORE("boost_system")
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index dfb9ccd7..6d9e257e 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -392,7 +392,7 @@ elseif(OSQUERY_BUILD_PLATFORM STREQUAL "windows")
- LOG_PLATFORM("Windows")
- endif()
-
--if("${OSQUERY_BUILD_DISTRO}" MATCHES "^(centos|rhel|scientific|oracle)7$")
-+if("${OSQUERY_BUILD_DISTRO}" MATCHES "^(centos|rhel|scientific|oracle)7$|arch")
- # Useful for libudev version detection.
- set(SYSTEMD TRUE)
- endif()
diff --git a/Makefile b/Makefile
index 2e2bd13c..c5ae915a 100644
--- a/Makefile
@@ -107,3 +94,16 @@ index 2e2bd13c..c5ae915a 100644
"--commit" "master" "-f" "--style=file"
ANALYSIS := ${SOURCE_DIR}/tools/analysis
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4444a9a2..b9c2640d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -393,6 +393,8 @@ endif()
+
+ if(APPLE)
+ LOG_PLATFORM("OS X")
++elseif(OSQUERY_BUILD_PLATFORM STREQUAL "arch")
++ LOG_PLATFORM("Arch Linux")
+ elseif(OSQUERY_BUILD_PLATFORM STREQUAL "debian")
+ LOG_PLATFORM("Debian")
+ elseif(OSQUERY_BUILD_PLATFORM STREQUAL "ubuntu")