summarylogtreecommitdiffstats
path: root/arch-linux.patch
diff options
context:
space:
mode:
authorTony Lambiris2018-08-27 22:07:07 -0400
committerTony Lambiris2018-08-27 22:07:07 -0400
commitaeb5209ec7d40b720ae5e6c6f38d485d83a3e682 (patch)
tree90ab96677f8e58a3231648ece47d28784d0b8f13 /arch-linux.patch
parent58c9d22f9d9110de7bf2d7e9c4db7a60bc256222 (diff)
downloadaur-aeb5209ec7d40b720ae5e6c6f38d485d83a3e682.tar.gz
Version bump
Diffstat (limited to 'arch-linux.patch')
-rw-r--r--arch-linux.patch16
1 files changed, 13 insertions, 3 deletions
diff --git a/arch-linux.patch b/arch-linux.patch
index 634c914f5418..f18cd01b1410 100644
--- a/arch-linux.patch
+++ b/arch-linux.patch
@@ -54,10 +54,20 @@ index 8efb6202..7f9d64aa 100644
ADD_OSQUERY_LINK_ADDITIONAL("blkid")
ADD_OSQUERY_LINK_ADDITIONAL("ip4tc")
diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 1c067c938..70f98f4b7 100644
+index c7b6b23b9..57b292ee7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -327,7 +327,6 @@ if (POSIX)
+@@ -176,9 +176,6 @@ if(NOT WIN32)
+ endif()
+
+ if(POSIX)
+- add_compile_options(
+- -Werror
+- )
+ if(CLANG)
+ add_compile_options(
+ -Qunused-arguments
+@@ -330,7 +327,6 @@ if (POSIX)
# To be safe, only include them when building 'release' outputs.
add_compile_options(
"$<$<CONFIG:RELEASE>:-g>"
@@ -65,7 +75,7 @@ index 1c067c938..70f98f4b7 100644
"$<$<CONFIG:RELEASE>:-fPIE>"
"$<$<CONFIG:RELEASE>:-fpie>"
"$<$<CONFIG:RELEASE>:-fPIC>"
-@@ -546,6 +545,8 @@ endif()
+@@ -555,6 +551,8 @@ endif()
if(APPLE)
LOG_PLATFORM("OS X")