summarylogtreecommitdiffstats
path: root/assimp.patch
diff options
context:
space:
mode:
authorAlex Hirzel2022-12-09 15:50:35 -0500
committerAlex Hirzel2022-12-09 15:50:35 -0500
commit09c424124639d32d816d41ff2a4b7bf79328846b (patch)
tree74ad528977b144fe826748974f28c4f5945bc21f /assimp.patch
parent6b92681001b6751d7a32530b9103ab702a05277b (diff)
downloadaur-09c424124639d32d816d41ff2a4b7bf79328846b.tar.gz
clean up dependencies where possible
Diffstat (limited to 'assimp.patch')
-rw-r--r--assimp.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/assimp.patch b/assimp.patch
new file mode 100644
index 000000000000..c3ef1f6543dd
--- /dev/null
+++ b/assimp.patch
@@ -0,0 +1,31 @@
+diff --git a/src/ext/CMakeLists.txt b/src/ext/CMakeLists.txt
+index 6b2690eb..bfdf5091 100644
+--- a/src/ext/CMakeLists.txt
++++ b/src/ext/CMakeLists.txt
+@@ -7,25 +7,7 @@ add_library(fast_float INTERFACE)
+ target_include_directories(fast_float INTERFACE fast_float/include)
+ target_link_libraries(luisa-render-ext INTERFACE fast_float)
+
+-#find_package(assimp CONFIG)
+-if (NOT assimp_FOUND)
+- set(ASSIMP_BUILD_ZLIB ON CACHE BOOL "" FORCE)
+- set(ASSIMP_BUILD_ASSIMP_TOOLS OFF CACHE BOOL "" FORCE)
+- set(ASSIMP_BUILD_TESTS OFF CACHE BOOL "" FORCE)
+- set(ASSIMP_INSTALL OFF CACHE BOOL "" FORCE)
+- set(ASSIMP_INJECT_DEBUG_POSTFIX OFF CACHE BOOL "" FORCE)
+- set(ASSIMP_NO_EXPORT ON CACHE BOOL "" FORCE)
+- set(ASSIMP_BUILD_ALL_IMPORTERS_BY_DEFAULT ON CACHE BOOL "" FORCE)
+- add_subdirectory(assimp)
+- set_target_properties(assimp PROPERTIES UNITY_BUILD OFF)
+- if (UNIX AND NOT APPLE)
+- target_compile_definitions(assimp PRIVATE USE_FILE32API=1)
+- endif ()
+- if (CMAKE_CXX_COMPILER_ID MATCHES "Clang" AND
+- CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 15.0)
+- target_compile_options(assimp PRIVATE -Wno-deprecated-non-prototype)
+- endif ()
+-endif ()
++find_package(assimp CONFIG)
+ target_link_libraries(luisa-render-ext INTERFACE assimp::assimp)
+
+ set(TINYEXR_BUILD_SAMPLE OFF CACHE BOOL "" FORCE)