summarylogtreecommitdiffstats
path: root/autoup.bash
diff options
context:
space:
mode:
authorTobias Borgert2022-06-22 09:40:35 +0200
committerTobias Borgert2022-06-22 09:40:35 +0200
commit3ed17d6767a1b50767a15998b797c645a040b945 (patch)
tree55ed92f37c9a02fa8109b54da20315909630e59a /autoup.bash
parentb0df0ea835d7ccfd5da7a2113dff92d9afdb25d3 (diff)
downloadaur-3ed17d6767a1b50767a15998b797c645a040b945.tar.gz
Update to v5.25.1. Added clean-up to autoup.bash.
Diffstat (limited to 'autoup.bash')
-rwxr-xr-xautoup.bash8
1 files changed, 8 insertions, 0 deletions
diff --git a/autoup.bash b/autoup.bash
index 26f26f64c04a..c362c4b8de75 100755
--- a/autoup.bash
+++ b/autoup.bash
@@ -5,24 +5,32 @@ if [ -z "$1" ]; then
fi
echo "Trying to auto-update this package to version ${1} ..."
+
+# Clean up
+rm -rf pkg src discover-*
+
+# Update the version in the PKGBUILD
sed -ri 's/pkgver=([0-9]+\.[0-9]+\.[0-9]+\.{0,1}[0-9]*)/pkgver='"${1}"'/' PKGBUILD
if [ "$?" -ne 0 ]; then
echo "Setting the version number in PKGBUILD failed."
exit 1
fi
+# Update the package sums in the PKGBUILD
updpkgsums
if [ "$?" -ne 0 ]; then
echo "Updating the checksums failed."
exit 1
fi
+# Update .SRCINFO
makepkg --printsrcinfo > .SRCINFO
if [ "$?" -ne 0 ]; then
echo "Recreating .SRCINFO failed."
exit 1
fi
+# Build & install the package
makepkg -si --noconfirm
if [ "$?" -ne 0 ]; then
echo "Building and installing the package failed."