summarylogtreecommitdiffstats
path: root/avida.patch
diff options
context:
space:
mode:
authorKuoi2022-08-28 23:17:13 +0100
committerKuoi2022-08-28 23:17:13 +0100
commit0cdb0651603cbaaec39be2042d203ada29164437 (patch)
tree2f34b14cfa51e4a0e9f981e0dd036cd91ea69b55 /avida.patch
parent3425567192b51c19c696de326f4a7c561e3223d5 (diff)
downloadaur-avida.tar.gz
2.14.0
Diffstat (limited to 'avida.patch')
-rw-r--r--avida.patch77
1 files changed, 57 insertions, 20 deletions
diff --git a/avida.patch b/avida.patch
index fffe9fcbb869..2fb0cae451ff 100644
--- a/avida.patch
+++ b/avida.patch
@@ -1,20 +1,57 @@
---- avida-2.12.3-src.orig/avida-core/source/analyze/cAnalyzeTreeStats_Gamma.cc 2012-02-02 22:50:29.000000000 +0600
-+++ avida-2.12.3-src/avida-core/source/analyze/cAnalyzeTreeStats_Gamma.cc 2012-05-08 19:32:18.793044457 +0600
-@@ -27,6 +27,7 @@
-
- #include <math.h>
- #include <iostream>
-+#include <cstdlib>
-
- using namespace std;
-
---- avida-2.12.3-src.orig/avida-core/source/tools/tArray.h 2012-02-02 22:50:29.000000000 +0600
-+++ avida-2.12.3-src/avida-core/source/tools/tArray.h 2012-05-08 19:33:04.783042892 +0600
-@@ -24,6 +24,7 @@
- #define tArray_h
-
- #include <cassert>
-+#include <cstdlib>
-
- #ifndef NULL
- #define NULL 0
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 30008d6..c9f1912 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -23,10 +23,11 @@ ENDIF(NOT WIN32)
+ ADD_SUBDIRECTORY(avida-core)
+
+ # Default location for installed software/configs/ docs is the build directory.
++IF(NOT CMAKE_INSTALL_PREFIX)
+ SET(CMAKE_INSTALL_PREFIX
+ "${PROJECT_BINARY_DIR}"
+ CACHE PATH
+ "Install path prefix, prepended onto install directories."
+ FORCE
+ )
+-
++ENDIF(NOT CMAKE_INSTALL_PREFIX)
+diff --git a/avida-core/CMakeLists.txt b/avida-core/CMakeLists.txt
+index d9d063e..30c4f6a 100644
+--- a/avida-core/CMakeLists.txt
++++ b/avida-core/CMakeLists.txt
+@@ -12,13 +12,14 @@ ENDIF(COMMAND cmake_policy)
+ # PROJECT_BINARY_DIR, since the project didn't exist yet.
+
+ # Default location for installed software/configs/ docs is the build directory.
++IF(NOT CMAKE_INSTALL_PREFIX)
+ SET(CMAKE_INSTALL_PREFIX
+ "${PROJECT_BINARY_DIR}"
+ CACHE PATH
+ "Install path prefix, prepended onto install directories."
+ FORCE
+ )
+-
++ENDIF(NOT CMAKE_INSTALL_PREFIX)
+ # Final software is built directly into the work subdirectory.
+ SET(EXECUTABLE_OUTPUT_PATH
+ "${PROJECT_BINARY_DIR}/bin"
+diff --git a/libs/tcmalloc-1.4/CMakeLists.txt b/libs/tcmalloc-1.4/CMakeLists.txt
+index 59f8f1a..54873b1 100644
+--- a/libs/tcmalloc-1.4/CMakeLists.txt
++++ b/libs/tcmalloc-1.4/CMakeLists.txt
+@@ -3,13 +3,14 @@ PROJECT(TCMALLOC CXX)
+ CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
+
+ # Default location for installed software/configs/ docs is the build directory.
++IF(NOT CMAKE_INSTALL_PREFIX)
+ SET(CMAKE_INSTALL_PREFIX
+ "${PROJECT_BINARY_DIR}"
+ CACHE PATH
+ "Install path prefix, prepended onto install directories."
+ FORCE
+ )
+-
++ENDIF(NOT CMAKE_INSTALL_PREFIX)
+ # Final software is built directly into the work subdirectory.
+ SET(EXECUTABLE_OUTPUT_PATH
+ "${PROJECT_BINARY_DIR}/bin"