summarylogtreecommitdiffstats
path: root/aws-cli-v2-bin.install
diff options
context:
space:
mode:
authorNick Syntychakis2024-05-16 21:18:23 +0000
committerNick Syntychakis2024-05-16 21:18:23 +0000
commitbc23c831cfc35b12c294f7c6b78b3549717e9a95 (patch)
treeafa05d6aa79bee2b7ea3b9afed8a398923b4cc71 /aws-cli-v2-bin.install
parent327b145be5bb6f57954bcd51ff5a741c016d40f6 (diff)
downloadaur-bc23c831cfc35b12c294f7c6b78b3549717e9a95.tar.gz
A simple PKGBUILD that install aws-cli v2 from the official binary
Diffstat (limited to 'aws-cli-v2-bin.install')
-rw-r--r--aws-cli-v2-bin.install12
1 files changed, 12 insertions, 0 deletions
diff --git a/aws-cli-v2-bin.install b/aws-cli-v2-bin.install
new file mode 100644
index 000000000000..118b791e81b2
--- /dev/null
+++ b/aws-cli-v2-bin.install
@@ -0,0 +1,12 @@
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ if [ "$(vercmp $2 2.13.25)" -le 0 ]; then
+ cat << EOF
+===> zsh completions are no longer automatically enabled.
+===> You can put the following line in a zsh startup script
+===> or run it manually before using aws zsh completions.
+===> source /usr/bin/aws_zsh_completer.sh
+EOF
+ fi
+}