summarylogtreecommitdiffstats
path: root/bctoolbox.patch
diff options
context:
space:
mode:
authorfrealgagu2018-11-18 18:22:22 -0500
committerfrealgagu2018-11-18 18:22:22 -0500
commitb91eb17ab282adc41deda36797b9dfa92064f9bf (patch)
tree09312f708df5ae1b42d3a2640074c9edfbdf84da /bctoolbox.patch
downloadaur-b91eb17ab282adc41deda36797b9dfa92064f9bf.tar.gz
Initial commit.
Diffstat (limited to 'bctoolbox.patch')
-rw-r--r--bctoolbox.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/bctoolbox.patch b/bctoolbox.patch
new file mode 100644
index 000000000000..718e1a270e69
--- /dev/null
+++ b/bctoolbox.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e14e502..187d55d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -43,7 +43,7 @@ option(ENABLE_SHARED "Build shared library." ON)
+ option(ENABLE_STATIC "Build static library." ON)
+ option(ENABLE_POLARSSL "Enable polarssl support" ON)
+ option(ENABLE_MBEDTLS "Enable mabedtls support" ON)
+-option(ENABLE_STRICT "Pass strict flags to the compiler" ON)
++option(ENABLE_STRICT "Pass strict flags to the compiler" OFF)
+ option(ENABLE_TESTS_COMPONENT "Enable compilation of tests helper library" ON)
+ option(ENABLE_TESTS "Enable compilation of tests" ON)
+