summarylogtreecommitdiffstats
path: root/binutils-bfd-djgpp.patch
diff options
context:
space:
mode:
authorAndris Pavenis2020-05-16 10:22:21 +0300
committerAndris Pavenis2020-05-16 10:23:54 +0300
commit8889e64c9a48d734442ad7d7b5db08ec35003816 (patch)
treeaea6e0b29307dba85cc87fd9319d3953d49c3b24 /binutils-bfd-djgpp.patch
parentb61913384d38e84a6520a6160cba4d600ede134d (diff)
downloadaur-djgpp-binutils.tar.gz
Update to binutils-2.34
- binutils*djgpp.patch files from DJGPP distribution package bnu234s.zip without changes
Diffstat (limited to 'binutils-bfd-djgpp.patch')
-rw-r--r--binutils-bfd-djgpp.patch232
1 files changed, 116 insertions, 116 deletions
diff --git a/binutils-bfd-djgpp.patch b/binutils-bfd-djgpp.patch
index be817a9b4e59..104e11c51413 100644
--- a/binutils-bfd-djgpp.patch
+++ b/binutils-bfd-djgpp.patch
@@ -2,7 +2,7 @@
# by the DJGPP ports of binutils and gdb.
-2019-02-13 Juan Manuel Guerrero <juan.guerrero@gmx.de>
+2020-03-01 Juan Manuel Guerrero <juan.guerrero@gmx.de>
* bfd/bfd-in.h [__DJGPP__]: Provide the declaration of
coff_64k_relocation_enabled.
@@ -133,24 +133,24 @@
-diff -aprNU5 binutils-2.32.orig/bfd/bfd-in.h binutils-2.32/bfd/bfd-in.h
---- binutils-2.32.orig/bfd/bfd-in.h 2019-01-19 16:01:32 +0000
-+++ binutils-2.32/bfd/bfd-in.h 2019-02-13 22:25:44 +0000
-@@ -1071,5 +1071,11 @@ extern bfd_boolean elf32_csky_size_stubs
- void (*) (void));
- extern void elf32_csky_next_input_section
- (struct bfd_link_info *, struct bfd_section *);
- extern int elf32_csky_setup_section_lists
- (bfd *, struct bfd_link_info *);
+diff -aprNU5 binutils-2.34.orig/bfd/bfd-in.h binutils-2.34/bfd/bfd-in.h
+--- binutils-2.34.orig/bfd/bfd-in.h 2020-01-18 13:55:46 +0000
++++ binutils-2.34/bfd/bfd-in.h 2020-03-01 19:17:02 +0000
+@@ -562,5 +562,11 @@ extern bfd *bfd_elf_bfd_from_remote_memo
+ struct ecoff_debug_info;
+ struct ecoff_debug_swap;
+ struct ecoff_extr;
+ struct bfd_link_info;
+ struct bfd_link_hash_entry;
+
+/* This controls if the coff 64k relocation support shall be disabled or not.
+ By default always enabled. */
+#if defined(__DJGPP__) || defined(COFF_GO32_EXE) || defined(COFF_GO32)
+extern bfd_boolean coff_64k_relocation_enabled;
+#endif
-diff -aprNU5 binutils-2.32.orig/bfd/cache.c binutils-2.32/bfd/cache.c
---- binutils-2.32.orig/bfd/cache.c 2019-01-19 16:01:32 +0000
-+++ binutils-2.32/bfd/cache.c 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/bfd/cache.c binutils-2.34/bfd/cache.c
+--- binutils-2.34.orig/bfd/cache.c 2020-01-18 13:55:46 +0000
++++ binutils-2.34/bfd/cache.c 2020-03-01 19:10:00 +0000
@@ -75,11 +75,11 @@ static int
bfd_cache_max_open (void)
{
@@ -164,9 +164,9 @@ diff -aprNU5 binutils-2.32.orig/bfd/cache.c binutils-2.32/bfd/cache.c
RLIMIT_NOFILE to a value that is not supported by libc, resulting
in "Too many open files" errors. This can happen here even though
max_open_files is set to rlim.rlim_cur / 8. For example, if
-diff -aprNU5 binutils-2.32.orig/bfd/coff-go32.c binutils-2.32/bfd/coff-go32.c
---- binutils-2.32.orig/bfd/coff-go32.c 2019-01-19 16:01:32 +0000
-+++ binutils-2.32/bfd/coff-go32.c 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/bfd/coff-go32.c binutils-2.34/bfd/coff-go32.c
+--- binutils-2.34.orig/bfd/coff-go32.c 2020-01-18 13:55:46 +0000
++++ binutils-2.34/bfd/coff-go32.c 2020-03-01 19:10:00 +0000
@@ -20,10 +20,11 @@
MA 02110-1301, USA. */
@@ -196,9 +196,9 @@ diff -aprNU5 binutils-2.32.orig/bfd/coff-go32.c binutils-2.32/bfd/coff-go32.c
+#define coff_mkobject _bfd_go32_mkobject
+
#include "coff-i386.c"
-diff -aprNU5 binutils-2.32.orig/bfd/coff-stgo32.c binutils-2.32/bfd/coff-stgo32.c
---- binutils-2.32.orig/bfd/coff-stgo32.c 2019-01-19 16:01:32 +0000
-+++ binutils-2.32/bfd/coff-stgo32.c 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/bfd/coff-stgo32.c binutils-2.34/bfd/coff-stgo32.c
+--- binutils-2.34.orig/bfd/coff-stgo32.c 2020-01-18 13:55:46 +0000
++++ binutils-2.34/bfd/coff-stgo32.c 2020-03-01 19:10:00 +0000
@@ -51,10 +51,13 @@
{ COFF_SECTION_NAME_PARTIAL_MATCH (".debug"), \
COFF_ALIGNMENT_FIELD_EMPTY, COFF_ALIGNMENT_FIELD_EMPTY, 0 }, \
@@ -260,9 +260,9 @@ diff -aprNU5 binutils-2.32.orig/bfd/coff-stgo32.c binutils-2.32/bfd/coff-stgo32.
+
+ return TRUE;
+}
-diff -aprNU5 binutils-2.32.orig/bfd/coffcode.h binutils-2.32/bfd/coffcode.h
---- binutils-2.32.orig/bfd/coffcode.h 2019-01-19 16:01:32 +0000
-+++ binutils-2.32/bfd/coffcode.h 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/bfd/coffcode.h binutils-2.34/bfd/coffcode.h
+--- binutils-2.34.orig/bfd/coffcode.h 2020-01-18 13:55:46 +0000
++++ binutils-2.34/bfd/coffcode.h 2020-03-01 19:10:00 +0000
@@ -362,10 +362,14 @@ CODE_FRAGMENT
#define DOT_ZDEBUG ".zdebug"
#define GNU_LINKONCE_WI ".gnu.linkonce.wi."
@@ -278,7 +278,7 @@ diff -aprNU5 binutils-2.32.orig/bfd/coffcode.h binutils-2.32/bfd/coffcode.h
#define COFFLONGSECTIONCATHELPER(x,y) x ## y
/* If the input macro Y is blank or '1', return an odd number; if it is
'0', return an even number. Result undefined in all other cases. */
-@@ -1950,17 +1954,57 @@ coff_set_alignment_hook (bfd *abfd, asec
+@@ -1953,17 +1957,57 @@ coff_set_alignment_hook (bfd *abfd, asec
}
}
@@ -336,7 +336,7 @@ diff -aprNU5 binutils-2.32.orig/bfd/coffcode.h binutils-2.32/bfd/coffcode.h
#endif /* ! COFF_ALIGN_IN_SECTION_HEADER */
#ifndef coff_mkobject
-@@ -2513,12 +2557,12 @@ coff_write_relocs (bfd * abfd, int first
+@@ -2521,12 +2565,12 @@ coff_write_relocs (bfd * abfd, int first
#endif
if (bfd_seek (abfd, s->rel_filepos, SEEK_SET) != 0)
@@ -351,7 +351,7 @@ diff -aprNU5 binutils-2.32.orig/bfd/coffcode.h binutils-2.32/bfd/coffcode.h
struct internal_reloc n;
memset (& n, 0, sizeof (n));
-@@ -3332,10 +3376,14 @@ coff_apply_checksum (bfd *abfd)
+@@ -3337,10 +3381,14 @@ coff_apply_checksum (bfd *abfd)
return TRUE;
}
@@ -366,7 +366,7 @@ diff -aprNU5 binutils-2.32.orig/bfd/coffcode.h binutils-2.32/bfd/coffcode.h
{
asection *current;
bfd_boolean hasrelocs = FALSE;
-@@ -3376,13 +3424,13 @@ coff_write_object_contents (bfd * abfd)
+@@ -3381,13 +3429,13 @@ coff_write_object_contents (bfd * abfd)
/* Work out the size of the reloc and linno areas. */
for (current = abfd->sections; current != NULL; current =
@@ -382,7 +382,7 @@ diff -aprNU5 binutils-2.32.orig/bfd/coffcode.h binutils-2.32/bfd/coffcode.h
reloc_count += current->reloc_count;
}
-@@ -3406,13 +3454,13 @@ coff_write_object_contents (bfd * abfd)
+@@ -3411,13 +3459,13 @@ coff_write_object_contents (bfd * abfd)
if (current->reloc_count)
{
@@ -398,7 +398,7 @@ diff -aprNU5 binutils-2.32.orig/bfd/coffcode.h binutils-2.32/bfd/coffcode.h
}
else
current->rel_filepos = 0;
-@@ -3743,10 +3791,22 @@ coff_write_object_contents (bfd * abfd)
+@@ -3748,10 +3796,22 @@ coff_write_object_contents (bfd * abfd)
}
}
#endif
@@ -421,10 +421,10 @@ diff -aprNU5 binutils-2.32.orig/bfd/coffcode.h binutils-2.32/bfd/coffcode.h
/* Don't include the internal abs section in the section count */
/* We will NOT put a fucking timestamp in the header here. Every time you
-diff -aprNU5 binutils-2.32.orig/bfd/cofflink.c binutils-2.32/bfd/cofflink.c
---- binutils-2.32.orig/bfd/cofflink.c 2019-01-19 16:01:32 +0000
-+++ binutils-2.32/bfd/cofflink.c 2019-02-13 22:25:44 +0000
-@@ -683,11 +683,11 @@ _bfd_coff_final_link (bfd *abfd,
+diff -aprNU5 binutils-2.34.orig/bfd/cofflink.c binutils-2.34/bfd/cofflink.c
+--- binutils-2.34.orig/bfd/cofflink.c 2020-01-18 13:55:46 +0000
++++ binutils-2.34/bfd/cofflink.c 2020-03-01 19:10:00 +0000
+@@ -687,11 +687,11 @@ _bfd_coff_final_link (bfd *abfd,
o->flags |= SEC_RELOC;
o->rel_filepos = rel_filepos;
rel_filepos += o->reloc_count * relsz;
@@ -437,7 +437,7 @@ diff -aprNU5 binutils-2.32.orig/bfd/cofflink.c binutils-2.32/bfd/cofflink.c
if (bfd_coff_long_section_names (abfd)
&& strlen (o->name) > SCNNMLEN)
-@@ -1102,11 +1102,11 @@ _bfd_coff_final_link (bfd *abfd,
+@@ -1106,11 +1106,11 @@ _bfd_coff_final_link (bfd *abfd,
bfd_coff_swap_reloc_out (abfd, irel, erel);
}
@@ -450,10 +450,10 @@ diff -aprNU5 binutils-2.32.orig/bfd/cofflink.c binutils-2.32/bfd/cofflink.c
reloc. The header overflow bit will be set
elsewhere. */
struct internal_reloc incount;
-diff -aprNU5 binutils-2.32.orig/bfd/coffswap.h binutils-2.32/bfd/coffswap.h
---- binutils-2.32.orig/bfd/coffswap.h 2019-01-19 16:01:32 +0000
-+++ binutils-2.32/bfd/coffswap.h 2019-02-13 22:25:44 +0000
-@@ -750,10 +750,23 @@ coff_swap_scnhdr_in (bfd * abfd, void *
+diff -aprNU5 binutils-2.34.orig/bfd/coffswap.h binutils-2.34/bfd/coffswap.h
+--- binutils-2.34.orig/bfd/coffswap.h 2020-01-18 13:55:46 +0000
++++ binutils-2.34/bfd/coffswap.h 2020-03-01 19:10:00 +0000
+@@ -744,10 +744,23 @@ coff_swap_scnhdr_in (bfd * abfd, void *
scnhdr_int->s_relptr = GET_SCNHDR_RELPTR (abfd, scnhdr_ext->s_relptr);
scnhdr_int->s_lnnoptr = GET_SCNHDR_LNNOPTR (abfd, scnhdr_ext->s_lnnoptr);
scnhdr_int->s_flags = GET_SCNHDR_FLAGS (abfd, scnhdr_ext->s_flags);
@@ -477,7 +477,7 @@ diff -aprNU5 binutils-2.32.orig/bfd/coffswap.h binutils-2.32/bfd/coffswap.h
#endif
}
-@@ -774,10 +787,65 @@ coff_swap_scnhdr_out (bfd * abfd, void *
+@@ -768,10 +781,65 @@ coff_swap_scnhdr_out (bfd * abfd, void *
PUT_SCNHDR_SIZE (abfd, scnhdr_int->s_size, scnhdr_ext->s_size);
PUT_SCNHDR_SCNPTR (abfd, scnhdr_int->s_scnptr, scnhdr_ext->s_scnptr);
PUT_SCNHDR_RELPTR (abfd, scnhdr_int->s_relptr, scnhdr_ext->s_relptr);
@@ -543,7 +543,7 @@ diff -aprNU5 binutils-2.32.orig/bfd/coffswap.h binutils-2.32/bfd/coffswap.h
else
{
char buf[sizeof (scnhdr_int->s_name) + 1];
-@@ -805,10 +873,13 @@ coff_swap_scnhdr_out (bfd * abfd, void *
+@@ -799,10 +867,13 @@ coff_swap_scnhdr_out (bfd * abfd, void *
bfd_set_error (bfd_error_file_truncated);
PUT_SCNHDR_NRELOC (abfd, 0xffff, scnhdr_ext->s_nreloc);
ret = 0;
@@ -557,9 +557,9 @@ diff -aprNU5 binutils-2.32.orig/bfd/coffswap.h binutils-2.32/bfd/coffswap.h
#endif
return ret;
}
-diff -aprNU5 binutils-2.32.orig/bfd/config.in binutils-2.32/bfd/config.in
---- binutils-2.32.orig/bfd/config.in 2019-02-02 15:48:02 +0000
-+++ binutils-2.32/bfd/config.in 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/bfd/config.in binutils-2.34/bfd/config.in
+--- binutils-2.34.orig/bfd/config.in 2020-02-01 11:49:18 +0000
++++ binutils-2.34/bfd/config.in 2020-03-01 19:10:00 +0000
@@ -414,5 +414,39 @@
this defined. */
#undef _POSIX_1_SOURCE
@@ -600,9 +600,9 @@ diff -aprNU5 binutils-2.32.orig/bfd/config.in binutils-2.32/bfd/config.in
+#else
+# define STRIP_FULL_PATH_AND_EXTENSION(file_name) (file_name)
+#endif
-diff -aprNU5 binutils-2.32.orig/bfd/init.c binutils-2.32/bfd/init.c
---- binutils-2.32.orig/bfd/init.c 2019-01-19 16:01:32 +0000
-+++ binutils-2.32/bfd/init.c 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/bfd/init.c binutils-2.34/bfd/init.c
+--- binutils-2.34.orig/bfd/init.c 2020-01-18 13:55:46 +0000
++++ binutils-2.34/bfd/init.c 2020-03-01 19:10:00 +0000
@@ -21,10 +21,16 @@
#include "sysdep.h"
@@ -634,9 +634,9 @@ diff -aprNU5 binutils-2.32.orig/bfd/init.c binutils-2.32/bfd/init.c
+#endif
return BFD_INIT_MAGIC;
}
-diff -aprNU5 binutils-2.32.orig/bfd/libcoff-in.h binutils-2.32/bfd/libcoff-in.h
---- binutils-2.32.orig/bfd/libcoff-in.h 2019-01-19 16:01:32 +0000
-+++ binutils-2.32/bfd/libcoff-in.h 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/bfd/libcoff-in.h binutils-2.34/bfd/libcoff-in.h
+--- binutils-2.34.orig/bfd/libcoff-in.h 2020-01-18 13:55:46 +0000
++++ binutils-2.34/bfd/libcoff-in.h 2020-03-01 19:10:00 +0000
@@ -31,12 +31,13 @@ extern "C" {
/* Object file tdata; access macros. */
@@ -665,10 +665,10 @@ diff -aprNU5 binutils-2.32.orig/bfd/libcoff-in.h binutils-2.32/bfd/libcoff-in.h
char *go32stub;
} coff_data_type;
-diff -aprNU5 binutils-2.32.orig/bfd/Makefile.in binutils-2.32/bfd/Makefile.in
---- binutils-2.32.orig/bfd/Makefile.in 2019-02-02 15:47:56 +0000
-+++ binutils-2.32/bfd/Makefile.in 2019-02-13 22:25:44 +0000
-@@ -2020,11 +2020,11 @@ host-aout.lo: Makefile
+diff -aprNU5 binutils-2.34.orig/bfd/Makefile.in binutils-2.34/bfd/Makefile.in
+--- binutils-2.34.orig/bfd/Makefile.in 2020-02-01 11:49:12 +0000
++++ binutils-2.34/bfd/Makefile.in 2020-03-01 19:10:00 +0000
+@@ -2033,11 +2033,11 @@ host-aout.lo: Makefile
aout-params.h: gen-aout
./gen-aout host > aout-params.h
gen-aout: $(srcdir)/gen-aout.c Makefile
@@ -681,7 +681,7 @@ diff -aprNU5 binutils-2.32.orig/bfd/Makefile.in binutils-2.32/bfd/Makefile.in
rm -f bfd-tmp.h
cp bfd-in3.h bfd-tmp.h
$(SHELL) $(srcdir)/../move-if-change bfd-tmp.h $(BFD_H)
-@@ -2042,11 +2042,11 @@ headers:
+@@ -2055,11 +2055,11 @@ headers:
$(SHELL) $(srcdir)/../move-if-change libcoff.h-new $(srcdir)/libcoff.h
# We only rebuild the header files automatically if we have been
@@ -694,10 +694,10 @@ diff -aprNU5 binutils-2.32.orig/bfd/Makefile.in binutils-2.32/bfd/Makefile.in
cp $(bfddocdir)/bfd.h bfd-in2.h-new
$(SHELL) $(srcdir)/../move-if-change bfd-in2.h-new $(srcdir)/bfd-in2.h
touch stmp-bin2-h
-diff -aprNU5 binutils-2.32.orig/include/bfdlink.h binutils-2.32/include/bfdlink.h
---- binutils-2.32.orig/include/bfdlink.h 2019-01-19 16:01:32 +0000
-+++ binutils-2.32/include/bfdlink.h 2019-02-13 22:25:44 +0000
-@@ -296,11 +296,11 @@ struct bfd_elf_version_tree;
+diff -aprNU5 binutils-2.34.orig/include/bfdlink.h binutils-2.34/include/bfdlink.h
+--- binutils-2.34.orig/include/bfdlink.h 2020-01-18 13:55:48 +0000
++++ binutils-2.34/include/bfdlink.h 2020-03-01 19:10:00 +0000
+@@ -302,11 +302,11 @@ struct bfd_elf_version_tree;
enum output_type
{
type_pde,
@@ -710,9 +710,9 @@ diff -aprNU5 binutils-2.32.orig/include/bfdlink.h binutils-2.32/include/bfdlink.
#define bfd_link_pde(info) ((info)->type == type_pde)
#define bfd_link_dll(info) ((info)->type == type_dll)
#define bfd_link_relocatable(info) ((info)->type == type_relocatable)
-diff -aprNU5 binutils-2.32.orig/include/coff/internal.h binutils-2.32/include/coff/internal.h
---- binutils-2.32.orig/include/coff/internal.h 2019-01-19 16:01:32 +0000
-+++ binutils-2.32/include/coff/internal.h 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/include/coff/internal.h binutils-2.34/include/coff/internal.h
+--- binutils-2.34.orig/include/coff/internal.h 2020-01-18 13:55:48 +0000
++++ binutils-2.34/include/coff/internal.h 2020-03-01 19:10:00 +0000
@@ -165,11 +165,11 @@ typedef struct _CODEVIEW_INFO
{
unsigned long CVSignature;
@@ -726,9 +726,9 @@ diff -aprNU5 binutils-2.32.orig/include/coff/internal.h binutils-2.32/include/co
/* Default image base for NT. */
#define NT_EXE_IMAGE_BASE 0x400000
#define NT_DLL_IMAGE_BASE 0x10000000
-diff -aprNU5 binutils-2.32.orig/include/simple-object.h binutils-2.32/include/simple-object.h
---- binutils-2.32.orig/include/simple-object.h 2019-01-19 16:01:32 +0000
-+++ binutils-2.32/include/simple-object.h 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/include/simple-object.h binutils-2.34/include/simple-object.h
+--- binutils-2.34.orig/include/simple-object.h 2020-01-18 13:55:48 +0000
++++ binutils-2.34/include/simple-object.h 2020-03-01 19:10:00 +0000
@@ -204,11 +204,11 @@ simple_object_release_write (simple_obje
If an error occurs, return the errno value in ERR and an error string. */
@@ -742,9 +742,9 @@ diff -aprNU5 binutils-2.32.orig/include/simple-object.h binutils-2.32/include/si
}
#endif
-diff -aprNU5 binutils-2.32.orig/libiberty/config.in binutils-2.32/libiberty/config.in
---- binutils-2.32.orig/libiberty/config.in 2019-01-19 16:01:34 +0000
-+++ binutils-2.32/libiberty/config.in 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/libiberty/config.in binutils-2.34/libiberty/config.in
+--- binutils-2.34.orig/libiberty/config.in 2020-01-18 13:55:48 +0000
++++ binutils-2.34/libiberty/config.in 2020-03-01 19:10:00 +0000
@@ -573,5 +573,59 @@
pointer, if such a type exists, and if the system does not define it. */
#undef uintptr_t
@@ -805,10 +805,10 @@ diff -aprNU5 binutils-2.32.orig/libiberty/config.in binutils-2.32/libiberty/conf
+#else /* !__DJGPP__ */
+# define STRIP_FULL_PATH_AND_EXTENSION(file_name) (file_name)
+#endif /* !__DJGPP__ */
-diff -aprNU5 binutils-2.32.orig/libiberty/cp-demangle.c binutils-2.32/libiberty/cp-demangle.c
---- binutils-2.32.orig/libiberty/cp-demangle.c 2019-01-19 16:01:34 +0000
-+++ binutils-2.32/libiberty/cp-demangle.c 2019-02-13 22:32:24 +0000
-@@ -2933,11 +2933,11 @@ d_parmlist (struct d_info *di)
+diff -aprNU5 binutils-2.34.orig/libiberty/cp-demangle.c binutils-2.34/libiberty/cp-demangle.c
+--- binutils-2.34.orig/libiberty/cp-demangle.c 2020-01-18 13:55:48 +0000
++++ binutils-2.34/libiberty/cp-demangle.c 2020-03-01 19:10:00 +0000
+@@ -2950,11 +2950,11 @@ d_parmlist (struct d_info *di)
}
/* <bare-function-type> ::= [J]<type>+ */
@@ -821,7 +821,7 @@ diff -aprNU5 binutils-2.32.orig/libiberty/cp-demangle.c binutils-2.32/libiberty/
struct demangle_component *tl;
char peek;
-@@ -2945,14 +2945,14 @@ d_bare_function_type (struct d_info *di,
+@@ -2962,14 +2962,14 @@ d_bare_function_type (struct d_info *di,
is the return type. */
peek = d_peek_char (di);
if (peek == 'J')
@@ -838,7 +838,7 @@ diff -aprNU5 binutils-2.32.orig/libiberty/cp-demangle.c binutils-2.32/libiberty/
if (return_type == NULL)
return NULL;
}
-@@ -3306,26 +3306,26 @@ d_expression_1 (struct d_info *di)
+@@ -3323,26 +3323,26 @@ d_expression_1 (struct d_info *di)
d_expression_1 (di), NULL);
}
else if (peek == 'f' && d_peek_next_char (di) == 'p')
@@ -871,7 +871,7 @@ diff -aprNU5 binutils-2.32.orig/libiberty/cp-demangle.c binutils-2.32/libiberty/
|| (peek == 'o' && d_peek_next_char (di) == 'n'))
{
/* We can get an unqualified name as an expression in the case of
-@@ -4649,11 +4649,11 @@ d_print_comp_inner (struct d_print_info
+@@ -4683,11 +4683,11 @@ d_print_comp_inner (struct d_print_info
without needing to modify *dc. */
struct demangle_component *mod_inner = NULL;
@@ -884,7 +884,7 @@ diff -aprNU5 binutils-2.32.orig/libiberty/cp-demangle.c binutils-2.32/libiberty/
int need_template_restore = 0;
if (dc == NULL)
-@@ -6236,11 +6236,11 @@ d_demangle_callback (const char *mangled
+@@ -6271,11 +6271,11 @@ d_demangle_callback (const char *mangled
DCT_GLOBAL_CTORS,
DCT_GLOBAL_DTORS
}
@@ -897,9 +897,9 @@ diff -aprNU5 binutils-2.32.orig/libiberty/cp-demangle.c binutils-2.32/libiberty/
if (mangled[0] == '_' && mangled[1] == 'Z')
type = DCT_MANGLED;
else if (strncmp (mangled, "_GLOBAL_", 8) == 0
-diff -aprNU5 binutils-2.32.orig/libiberty/floatformat.c binutils-2.32/libiberty/floatformat.c
---- binutils-2.32.orig/libiberty/floatformat.c 2019-01-19 16:01:34 +0000
-+++ binutils-2.32/libiberty/floatformat.c 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/libiberty/floatformat.c binutils-2.34/libiberty/floatformat.c
+--- binutils-2.34.orig/libiberty/floatformat.c 2020-01-18 13:55:48 +0000
++++ binutils-2.34/libiberty/floatformat.c 2020-03-01 19:10:00 +0000
@@ -484,20 +484,20 @@ floatformat_to_double (const struct floa
/* If the exponent indicates a NaN, we don't have information to
decide what to do. So we handle it like IEEE, except that we
@@ -907,25 +907,25 @@ diff -aprNU5 binutils-2.32.orig/libiberty/floatformat.c binutils-2.32/libiberty/
if ((unsigned long) exponent == fmt->exp_nan)
{
- int nan = mant_bits_set (fmt, ufrom);
-+ int _nan = mant_bits_set (fmt, ufrom);
++ int bfd_nan = mant_bits_set (fmt, ufrom);
/* On certain systems (such as GNU/Linux), the use of the
- INFINITY macro below may generate a warning that can not be
+ INFINITY macro below may generate a warning that cannot be
silenced due to a bug in GCC (PR preprocessor/11931). The
preprocessor fails to recognise the __extension__ keyword in
conjunction with the GNU/C99 extension for hexadecimal
floating point constants and will issue a warning when
compiling with -pedantic. */
- if (nan)
-+ if (_nan)
++ if (bfd_nan)
dto = NAN;
else
dto = INFINITY;
if (get_field (ufrom, fmt->byteorder, fmt->totalsize, fmt->sign_start, 1))
-diff -aprNU5 binutils-2.32.orig/libiberty/hashtab.c binutils-2.32/libiberty/hashtab.c
---- binutils-2.32.orig/libiberty/hashtab.c 2019-01-19 16:01:34 +0000
-+++ binutils-2.32/libiberty/hashtab.c 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/libiberty/hashtab.c binutils-2.34/libiberty/hashtab.c
+--- binutils-2.34.orig/libiberty/hashtab.c 2020-01-18 13:55:48 +0000
++++ binutils-2.34/libiberty/hashtab.c 2020-03-01 19:10:00 +0000
@@ -478,28 +478,28 @@ htab_empty (htab_t htab)
HASH is the hash value for the element to be inserted. */
@@ -1080,9 +1080,9 @@ diff -aprNU5 binutils-2.32.orig/libiberty/hashtab.c binutils-2.32/libiberty/hash
/* Like htab_find_slot_with_hash, but compute the hash value from the
element. */
-diff -aprNU5 binutils-2.32.orig/libiberty/make-relative-prefix.c binutils-2.32/libiberty/make-relative-prefix.c
---- binutils-2.32.orig/libiberty/make-relative-prefix.c 2019-01-19 16:01:34 +0000
-+++ binutils-2.32/libiberty/make-relative-prefix.c 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/libiberty/make-relative-prefix.c binutils-2.34/libiberty/make-relative-prefix.c
+--- binutils-2.34.orig/libiberty/make-relative-prefix.c 2020-01-18 13:55:48 +0000
++++ binutils-2.34/libiberty/make-relative-prefix.c 2020-03-01 19:10:00 +0000
@@ -79,10 +79,11 @@ relative prefix can be found, return @co
#if defined (_WIN32) || defined (__MSDOS__) \
|| defined (__DJGPP__) || defined (__OS2__)
@@ -1109,7 +1109,7 @@ diff -aprNU5 binutils-2.32.orig/libiberty/make-relative-prefix.c binutils-2.32/l
static char *save_string (const char *, int);
static char **split_directories (const char *, int *);
static void free_split_directories (char **);
-@@ -335,11 +339,11 @@ make_relative_prefix_1 (const char *prog
+@@ -338,11 +342,11 @@ make_relative_prefix_1 (const char *prog
we can do. */
if (prog_num == bin_num)
{
@@ -1122,7 +1122,7 @@ diff -aprNU5 binutils-2.32.orig/libiberty/make-relative-prefix.c binutils-2.32/l
if (prog_num <= 0 || i == bin_num)
goto bailout;
-@@ -351,11 +355,11 @@ make_relative_prefix_1 (const char *prog
+@@ -354,11 +358,11 @@ make_relative_prefix_1 (const char *prog
/* Find how many directories are in common between bin_prefix & prefix. */
n = (prefix_num < bin_num) ? prefix_num : bin_num;
@@ -1135,9 +1135,9 @@ diff -aprNU5 binutils-2.32.orig/libiberty/make-relative-prefix.c binutils-2.32/l
/* If there are no common directories, there can be no relative prefix. */
if (common == 0)
-diff -aprNU5 binutils-2.32.orig/libiberty/make-temp-file.c binutils-2.32/libiberty/make-temp-file.c
---- binutils-2.32.orig/libiberty/make-temp-file.c 2019-01-19 16:01:34 +0000
-+++ binutils-2.32/libiberty/make-temp-file.c 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/libiberty/make-temp-file.c binutils-2.34/libiberty/make-temp-file.c
+--- binutils-2.34.orig/libiberty/make-temp-file.c 2020-01-18 13:55:48 +0000
++++ binutils-2.34/libiberty/make-temp-file.c 2020-03-01 19:10:00 +0000
@@ -52,16 +52,31 @@ extern int mkstemps (char *, int);
/* '/' works just fine on MS-DOS based systems. */
#ifndef DIR_SEPARATOR
@@ -1198,9 +1198,9 @@ diff -aprNU5 binutils-2.32.orig/libiberty/make-temp-file.c binutils-2.32/libiber
#else /* defined(_WIN32) && !defined(__CYGWIN__) */
DWORD len;
-diff -aprNU5 binutils-2.32.orig/libiberty/pex-common.c binutils-2.32/libiberty/pex-common.c
---- binutils-2.32.orig/libiberty/pex-common.c 2019-01-19 16:01:34 +0000
-+++ binutils-2.32/libiberty/pex-common.c 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/libiberty/pex-common.c binutils-2.34/libiberty/pex-common.c
+--- binutils-2.34.orig/libiberty/pex-common.c 2020-01-18 13:55:48 +0000
++++ binutils-2.34/libiberty/pex-common.c 2020-03-01 19:10:00 +0000
@@ -115,11 +115,11 @@ temp_file (struct pex_obj *obj, int flag
if (len >= 6
@@ -1240,9 +1240,9 @@ diff -aprNU5 binutils-2.32.orig/libiberty/pex-common.c binutils-2.32/libiberty/p
obj->next_input = -1;
}
else if ((obj->flags & PEX_USE_PIPES) == 0)
-diff -aprNU5 binutils-2.32.orig/libiberty/simple-object-coff.c binutils-2.32/libiberty/simple-object-coff.c
---- binutils-2.32.orig/libiberty/simple-object-coff.c 2019-01-19 16:01:34 +0000
-+++ binutils-2.32/libiberty/simple-object-coff.c 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/libiberty/simple-object-coff.c binutils-2.34/libiberty/simple-object-coff.c
+--- binutils-2.34.orig/libiberty/simple-object-coff.c 2020-01-18 13:55:48 +0000
++++ binutils-2.34/libiberty/simple-object-coff.c 2020-03-01 19:10:00 +0000
@@ -649,17 +649,17 @@ simple_object_coff_write_to_file (simple
new_offset = offset & mask;
new_offset &= ~ mask;
@@ -1266,10 +1266,10 @@ diff -aprNU5 binutils-2.32.orig/libiberty/simple-object-coff.c binutils-2.32/lib
}
scnsize = 0;
-diff -aprNU5 binutils-2.32.orig/libiberty/simple-object-elf.c binutils-2.32/libiberty/simple-object-elf.c
---- binutils-2.32.orig/libiberty/simple-object-elf.c 2019-01-19 16:01:34 +0000
-+++ binutils-2.32/libiberty/simple-object-elf.c 2019-02-13 22:25:44 +0000
-@@ -990,20 +990,20 @@ simple_object_elf_write_to_file (simple_
+diff -aprNU5 binutils-2.34.orig/libiberty/simple-object-elf.c binutils-2.34/libiberty/simple-object-elf.c
+--- binutils-2.34.orig/libiberty/simple-object-elf.c 2020-01-18 13:55:48 +0000
++++ binutils-2.34/libiberty/simple-object-elf.c 2020-03-01 19:10:00 +0000
+@@ -998,20 +998,20 @@ simple_object_elf_write_to_file (simple_
new_sh_offset = sh_offset + mask;
new_sh_offset &= ~ mask;
while (new_sh_offset > sh_offset)
@@ -1296,9 +1296,9 @@ diff -aprNU5 binutils-2.32.orig/libiberty/simple-object-elf.c binutils-2.32/libi
sh_size = 0;
for (buffer = section->buffers; buffer != NULL; buffer = buffer->next)
{
-diff -aprNU5 binutils-2.32.orig/libiberty/simple-object-mach-o.c binutils-2.32/libiberty/simple-object-mach-o.c
---- binutils-2.32.orig/libiberty/simple-object-mach-o.c 2019-01-19 16:01:34 +0000
-+++ binutils-2.32/libiberty/simple-object-mach-o.c 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/libiberty/simple-object-mach-o.c binutils-2.34/libiberty/simple-object-mach-o.c
+--- binutils-2.34.orig/libiberty/simple-object-mach-o.c 2020-01-18 13:55:48 +0000
++++ binutils-2.34/libiberty/simple-object-mach-o.c 2020-03-01 19:10:00 +0000
@@ -424,11 +424,11 @@ simple_object_mach_o_segment (simple_obj
unsigned int index_index;
unsigned int nametab_index;
@@ -1567,9 +1567,9 @@ diff -aprNU5 binutils-2.32.orig/libiberty/simple-object-mach-o.c binutils-2.32/l
/* Write out the segment header. */
-diff -aprNU5 binutils-2.32.orig/libiberty/simple-object-xcoff.c binutils-2.32/libiberty/simple-object-xcoff.c
---- binutils-2.32.orig/libiberty/simple-object-xcoff.c 2019-01-19 16:01:34 +0000
-+++ binutils-2.32/libiberty/simple-object-xcoff.c 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/libiberty/simple-object-xcoff.c binutils-2.34/libiberty/simple-object-xcoff.c
+--- binutils-2.34.orig/libiberty/simple-object-xcoff.c 2020-01-18 13:55:48 +0000
++++ binutils-2.34/libiberty/simple-object-xcoff.c 2020-03-01 19:10:00 +0000
@@ -905,17 +905,17 @@ simple_object_xcoff_write_to_file (simpl
new_offset = offset & mask;
new_offset &= ~ mask;
@@ -1593,10 +1593,10 @@ diff -aprNU5 binutils-2.32.orig/libiberty/simple-object-xcoff.c binutils-2.32/li
}
scnsize = 0;
-diff -aprNU5 binutils-2.32.orig/libiberty/simple-object.c binutils-2.32/libiberty/simple-object.c
---- binutils-2.32.orig/libiberty/simple-object.c 2019-01-19 16:01:34 +0000
-+++ binutils-2.32/libiberty/simple-object.c 2019-02-13 22:25:44 +0000
-@@ -254,40 +254,40 @@ simple_object_find_section (simple_objec
+diff -aprNU5 binutils-2.34.orig/libiberty/simple-object.c binutils-2.34/libiberty/simple-object.c
+--- binutils-2.34.orig/libiberty/simple-object.c 2020-01-18 13:55:48 +0000
++++ binutils-2.34/libiberty/simple-object.c 2020-03-01 19:10:00 +0000
+@@ -258,40 +258,40 @@ simple_object_find_section (simple_objec
Returns non-NULL if NAME is a LTO debug section, NULL if not.
If RENAME is true it will rename LTO debug sections to non-LTO
ones. */
@@ -1643,7 +1643,7 @@ diff -aprNU5 binutils-2.32.orig/libiberty/simple-object.c binutils-2.32/libibert
return strcpy (newname, name);
/* Copy over .comment section under the same name if present. Solaris
ld uses them to relax its checking of ELF gABI access rules for
-@@ -316,11 +316,11 @@ handle_lto_debug_sections_norename (cons
+@@ -320,11 +320,11 @@ handle_lto_debug_sections_norename (cons
/* Copy LTO debug sections. */
@@ -1656,7 +1656,7 @@ diff -aprNU5 binutils-2.32.orig/libiberty/simple-object.c binutils-2.32/libibert
simple_object_write *dest_sobj;
simple_object_attributes *attrs;
int outfd;
-@@ -339,11 +339,11 @@ simple_object_copy_lto_debug_sections (s
+@@ -343,11 +343,11 @@ simple_object_copy_lto_debug_sections (s
if (! dest_sobj)
return errmsg;
@@ -1669,9 +1669,9 @@ diff -aprNU5 binutils-2.32.orig/libiberty/simple-object.c binutils-2.32/libibert
{
simple_object_release_write (dest_sobj);
return errmsg;
-diff -aprNU5 binutils-2.32.orig/libiberty/stack-limit.c binutils-2.32/libiberty/stack-limit.c
---- binutils-2.32.orig/libiberty/stack-limit.c 2019-01-19 16:01:34 +0000
-+++ binutils-2.32/libiberty/stack-limit.c 2019-02-13 22:25:44 +0000
+diff -aprNU5 binutils-2.34.orig/libiberty/stack-limit.c binutils-2.34/libiberty/stack-limit.c
+--- binutils-2.34.orig/libiberty/stack-limit.c 2020-01-18 13:55:48 +0000
++++ binutils-2.34/libiberty/stack-limit.c 2020-03-01 19:10:00 +0000
@@ -49,11 +49,11 @@ stack_limit_increase (unsigned long pref
#if defined(HAVE_SETRLIMIT) && defined(HAVE_GETRLIMIT) \
&& defined(RLIMIT_STACK) && defined(RLIM_INFINITY)