summarylogtreecommitdiffstats
path: root/bool-to-null-ptr.patch
diff options
context:
space:
mode:
authorJames An2017-05-21 23:32:20 -0400
committerJames An2017-05-21 23:32:20 -0400
commit565f3e9f004be0dc8e972d45c8ba0d91f8bfb4aa (patch)
treef5a886c4bb98ceefc298990228fb798f559c2d94 /bool-to-null-ptr.patch
downloadaur-565f3e9f004be0dc8e972d45c8ba0d91f8bfb4aa.tar.gz
Initial commit with working PKGBUILD.
Diffstat (limited to 'bool-to-null-ptr.patch')
-rw-r--r--bool-to-null-ptr.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/bool-to-null-ptr.patch b/bool-to-null-ptr.patch
new file mode 100644
index 000000000000..8ac00022d06e
--- /dev/null
+++ b/bool-to-null-ptr.patch
@@ -0,0 +1,13 @@
+diff --git a/IndexSearch/ModuleFactory.cpp b/IndexSearch/ModuleFactory.cpp
+index 01cad8b7..fb5f08d2 100644
+--- a/IndexSearch/ModuleFactory.cpp
++++ b/IndexSearch/ModuleFactory.cpp
+@@ -132,7 +132,7 @@ IndexInterface *ModuleFactory::getLibraryIndex(const string &type, const string
+ (typeIter->second.m_canIndex == false))
+ {
+ // We don't know about this type, or doesn't support indexes
+- return false;
++ return NULL;
+ }
+
+ void *pHandle = typeIter->second.m_pHandle;