summarylogtreecommitdiffstats
path: root/boost.patch
diff options
context:
space:
mode:
authorPeter Ivanov2015-06-23 10:30:43 +0200
committerPeter Ivanov2015-06-23 10:30:43 +0200
commita824f3c7a458f5f472bd76ac4d110627daa50c62 (patch)
tree94abcca48a28a97eb6ecff3dc6c18b12696687d2 /boost.patch
downloadaur-a824f3c7a458f5f472bd76ac4d110627daa50c62.tar.gz
Initial import
Diffstat (limited to 'boost.patch')
-rw-r--r--boost.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/boost.patch b/boost.patch
new file mode 100644
index 000000000000..e7d1b2aceb99
--- /dev/null
+++ b/boost.patch
@@ -0,0 +1,11 @@
+--- ./emc/rs274ngc/rs274ngc_pre.cc 2014-10-22 06:40:15.674483981 +0200
++++ ./emc/rs274ngc/rs274ngc_pre.cc 2014-10-22 06:40:30.550990352 +0200
+@@ -129,7 +129,7 @@
+ // since interp.init() may be called repeatedly this would create a new
+ // wrapper instance on every init(), abandoning the old one and all user attributes
+ // tacked onto it, so make sure this is done exactly once
+- _setup.pythis = boost::python::object(boost::cref(this));
++ _setup.pythis = boost::python::object(boost::cref(*this));
+
+ // alias to 'interpreter.this' for the sake of ';py, .... ' comments
+ // besides 'this', eventually use proper instance names to handle