summarylogtreecommitdiffstats
path: root/boost_include_dirs.patch
diff options
context:
space:
mode:
authorFelix Exner2021-01-28 22:47:06 +0100
committerFelix Exner2021-01-28 22:47:06 +0100
commit88e10dceba8dada20355e05e33abac6b9fbd99d6 (patch)
tree01377605d48093561be587ad3b9c712b4db69203 /boost_include_dirs.patch
parent55a39fd8c8302b46c39758983813daae2487797d (diff)
downloadaur-88e10dceba8dada20355e05e33abac6b9fbd99d6.tar.gz
Add Boost_include_dirs to cmake include_dirs
This seems to be necessary because of our own boost installation
Diffstat (limited to 'boost_include_dirs.patch')
-rw-r--r--boost_include_dirs.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/boost_include_dirs.patch b/boost_include_dirs.patch
new file mode 100644
index 000000000000..9d09a26944a0
--- /dev/null
+++ b/boost_include_dirs.patch
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.old 2021-01-28 22:37:28.458179329 +0100
++++ CMakeLists.txt 2021-01-28 22:36:56.678194692 +0100
+@@ -56,7 +56,7 @@
+
+ ## Specify additional locations of header files
+ ## Your package locations should be listed before other locations
+-include_directories(include ${catkin_INCLUDE_DIRS})
++include_directories(include ${catkin_INCLUDE_DIRS} ${Boost_INCLUDE_DIRS})
+ if(WITH_LTTNG)
+ include_directories(${LTTNG_INCLUDEDIR})
+ endif()