summarylogtreecommitdiffstats
path: root/build-fixes.patch
diff options
context:
space:
mode:
authorChih-Hsuan Yen2022-10-25 19:00:16 +0800
committerChih-Hsuan Yen2022-10-25 19:00:16 +0800
commit58086ca4650eddd8024f3ad58e7b996160c71bda (patch)
tree2881d2a615b3b479dfa055e173c7c397a9ec990b /build-fixes.patch
parent2cbe23f1995763dd0cfcd60c896ba3eba1a0ce07 (diff)
downloadaur-58086ca4650eddd8024f3ad58e7b996160c71bda.tar.gz
python-onnxruntime: split C++ and Python libraries & some other changes
* Rename python-onnxruntime-cuda to onnxruntime-cuda - this split package actually does not contain Python libraries. * Move optdepends to the correct package * Drop flatbuffers fix after upstream adds the compatibility back [1] * Improve onednn patch - fallback to bundled onednn if the system one is missing & wrap other usage of `DNNL_DLL_PATH` * Add CUDA architectures introduced in CUDA 11.8. See [2] * Refresh patches for 1.13 [1] https://github.com/google/flatbuffers/issues/7499 [2] https://github.com/archlinux/svntogit-community/commit/54642de5ba70f8c67ad6c16815dd31138ba47456
Diffstat (limited to 'build-fixes.patch')
-rw-r--r--build-fixes.patch21
1 files changed, 2 insertions, 19 deletions
diff --git a/build-fixes.patch b/build-fixes.patch
index 2e86341c4d4b..a0b9b3c3e060 100644
--- a/build-fixes.patch
+++ b/build-fixes.patch
@@ -25,29 +25,12 @@ index a027c69e0..eb7608518 100644
message("Use re2 from preinstalled system lib")
else()
add_subdirectory(external/re2 EXCLUDE_FROM_ALL)
-@@ -1421,11 +1421,11 @@
- #Dependencies end. In the next we'll enable "treat warning as error"
-
- if (onnxruntime_PREFER_SYSTEM_LIB)
-- find_package(Flatbuffers)
-+ find_package(FlatBuffers)
+@@ -1421,7 +1421,7 @@
endif()
--if (Flatbuffers_FOUND)
-+if (FlatBuffers_FOUND)
+ if (Flatbuffers_FOUND)
message("Use flatbuffers from preinstalled system lib")
- add_library(flatbuffers ALIAS flatbuffers::flatbuffers)
+ add_library(flatbuffers ALIAS flatbuffers::flatbuffers_shared)
else()
message("Use flatbuffers from submodule")
# We do not need to build flatc for iOS or Android Cross Compile
---- a/setup.py 2022-07-22 17:00:19.638893453 +0800
-+++ b/setup.py 2022-07-22 17:02:00.686317628 +0800
-@@ -16,7 +16,7 @@
-
- from setuptools import Extension, setup
- from setuptools.command.install import install as InstallCommandBase
--from wheel.vendored.packaging.tags import sys_tags
-+from packaging.tags import sys_tags
-
- nightly_build = False
- package_name = "onnxruntime"