summarylogtreecommitdiffstats
path: root/build-fixes.patch
diff options
context:
space:
mode:
authorlilac2020-07-18 19:01:05 +0800
committerlilac2020-07-18 19:01:05 +0800
commit978405e1cc7badf3c4d661963c7b850f80dec649 (patch)
treeabcdc509af44b85da7e897dfa40a3ebe911cbff0 /build-fixes.patch
parentd218a459beecc1e2845309c3fdb52cfbf459e2fb (diff)
downloadaur-978405e1cc7badf3c4d661963c7b850f80dec649.tar.gz
[lilac] updated to 1.4.0-2
Diffstat (limited to 'build-fixes.patch')
-rw-r--r--build-fixes.patch64
1 files changed, 0 insertions, 64 deletions
diff --git a/build-fixes.patch b/build-fixes.patch
index dc1e234dcdab..2a0487ca6067 100644
--- a/build-fixes.patch
+++ b/build-fixes.patch
@@ -2,15 +2,6 @@ diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index 3cee60f3..3328fc06 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
-@@ -314,7 +314,7 @@ list(APPEND CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/external)
-
- if(onnxruntime_PREFER_SYSTEM_LIB)
- set(protobuf_MODULE_COMPATIBLE ON)
-- find_package(protobuf)
-+ find_package(Protobuf)
- endif()
-
-
@@ -327,7 +327,7 @@ if(Protobuf_FOUND OR Protobuf_FOUND)
if(NOT Protobuf_USE_STATIC_LIBS)
#Indeed here should be a warning, not a fatal error. ONNX Runtime itself can work in such a
@@ -29,32 +20,6 @@ index 3cee60f3..3328fc06 100644
if(onnxruntime_PREFER_SYSTEM_LIB)
find_package(re2)
-@@ -1009,18 +1009,19 @@
- # some of the tests rely on the shared libs to be
- # built; hence the ordering
- if (onnxruntime_BUILD_UNIT_TESTS)
-- if (onnxruntime_ENABLE_PYTHON)
-- if(UNIX)
-- set(CMAKE_SKIP_BUILD_RPATH ON)
-- endif()
-- include(onnxruntime_python.cmake)
-- endif()
- # we need to make sure this is turned off since it
- # turned ON by the previous step when building a shared lib
- set(CMAKE_SKIP_BUILD_RPATH OFF)
- include(onnxruntime_unittests.cmake)
- endif()
-
-+if (onnxruntime_ENABLE_PYTHON)
-+ if(UNIX)
-+ set(CMAKE_SKIP_BUILD_RPATH ON)
-+ endif()
-+ include(onnxruntime_python.cmake)
-+endif()
-+
- if (onnxruntime_ENABLE_TRAINING)
- include(onnxruntime_training.cmake)
- if (onnxruntime_ENABLE_TRAINING_E2E_TESTS)
diff --git a/cmake/external/Findre2.cmake b/cmake/external/Findre2.cmake
new file mode 100644
index 00000000..4c91696c
@@ -77,35 +42,6 @@ index d33e9e14..5770e818 100644
target_include_directories(onnxruntime_common
PRIVATE ${CMAKE_CURRENT_BINARY_DIR} ${ONNXRUNTIME_ROOT} ${eigen_INCLUDE_DIRS}
# safeint is part of onnxruntime_common public interface, so we want to propagate its includes
-diff --git a/cmake/onnxruntime_python.cmake b/cmake/onnxruntime_python.cmake
-index 7dce1309..7102975b 100644
---- a/cmake/onnxruntime_python.cmake
-+++ b/cmake/onnxruntime_python.cmake
-@@ -1,7 +1,6 @@
- # Copyright (c) Microsoft Corporation. All rights reserved.
- # Licensed under the MIT License.
-
--include(pybind11)
- FIND_PACKAGE(NumPy)
-
- if(NOT PYTHON_INCLUDE_DIR)
-@@ -99,7 +98,6 @@ endif()
-
- set(onnxruntime_pybind11_state_dependencies
- ${onnxruntime_EXTERNAL_DEPENDENCIES}
-- ${pybind11_dep}
- )
- set_property(TARGET onnxruntime_pybind11_state APPEND_STRING PROPERTY LINK_FLAGS ${ONNXRUNTIME_SO_LINK_FLAG} ${onnxruntime_DELAYLOAD_FLAGS})
- add_dependencies(onnxruntime_pybind11_state ${onnxruntime_pybind11_state_dependencies})
-@@ -192,7 +190,7 @@
- "${ONNXRUNTIME_ROOT}/python/datasets/*.onnx"
- )
-
--set(test_data_target onnxruntime_test_all)
-+set(test_data_target onnxruntime_pybind11_state)
-
- add_custom_command(
- TARGET onnxruntime_pybind11_state POST_BUILD
diff --git a/cmake/onnxruntime_unittests.cmake b/cmake/onnxruntime_unittests.cmake
index d1bd347c..0c4b81e4 100644
--- a/cmake/onnxruntime_unittests.cmake