summarylogtreecommitdiffstats
path: root/build.sh
diff options
context:
space:
mode:
authorJohan Brandhorst2022-01-18 15:45:38 -0500
committerJohan Brandhorst2022-01-18 15:45:38 -0500
commit7557c0c08e1a9fbdd557b21af8c23982b96f4a3d (patch)
tree31466a419a6306636885147db5ce695386d1e2b2 /build.sh
parentce954a6a814703b8a0e8553fece959a2b093af34 (diff)
downloadaur-7557c0c08e1a9fbdd557b21af8c23982b96f4a3d.tar.gz
Fix build script
We sometimes need to update the trusted keyring before installing packages
Diffstat (limited to 'build.sh')
-rwxr-xr-xbuild.sh1
1 files changed, 1 insertions, 0 deletions
diff --git a/build.sh b/build.sh
index c2df154d3401..fd2e0fa00d48 100755
--- a/build.sh
+++ b/build.sh
@@ -7,6 +7,7 @@ docker run \
--entrypoint /usr/bin/bash \
--workdir /srv \
docker.io/archlinux -c '\
+ pacman -Sy --noconfirm archlinux-keyring && \
pacman -Syu --noconfirm pacman-contrib pacman git sudo binutils go gcc && \
git clean -fdx && \
chmod a+w PKGBUILD .SRCINFO . && \