summarylogtreecommitdiffstats
path: root/build_info.patch
diff options
context:
space:
mode:
authorJerry Y. Chen2021-07-13 05:52:11 +0800
committerJerry Y. Chen2021-07-13 05:52:11 +0800
commit6d1a51418e951ad579f0c3245e22687fff5dd18e (patch)
tree32ad591f37dc1b1e8f900403e7a852822b49f612 /build_info.patch
parentedfd18a0ce163f3713e090adfa4699b077836547 (diff)
downloadaur-6d1a51418e951ad579f0c3245e22687fff5dd18e.tar.gz
update: merge official skaffold 1.27.0-1
Diffstat (limited to 'build_info.patch')
-rw-r--r--build_info.patch13
1 files changed, 7 insertions, 6 deletions
diff --git a/build_info.patch b/build_info.patch
index cb1af7991390..9b587d8219b3 100644
--- a/build_info.patch
+++ b/build_info.patch
@@ -1,9 +1,9 @@
diff --git a/Makefile b/Makefile
-index b5c88bd6e..a5c95d273 100644
+index dd22ea0..aa47490 100644
--- a/Makefile
+++ b/Makefile
-@@ -36,7 +36,8 @@ SKAFFOLD_TEST_PACKAGES = ./pkg/skaffold/... ./cmd/... ./hack/... ./pkg/webhook/.
- GO_FILES = $(shell find . -type f -name '*.go' -not -path "./pkg/diag/*")
+@@ -35,7 +35,8 @@ SKAFFOLD_TEST_PACKAGES = ./pkg/skaffold/... ./cmd/... ./hack/... ./pkg/webhook/.
+ GO_FILES = $(shell find . -type f -name '*.go' -not -path "./vendor/*" -not -path "./pkg/diag/*")
VERSION_PACKAGE = $(REPOPATH)/pkg/skaffold/version
-COMMIT = $(shell git rev-parse HEAD)
@@ -11,12 +11,13 @@ index b5c88bd6e..a5c95d273 100644
+TREE_STATE ?= $(if $(shell git status --porcelain),dirty,clean)
ifeq "$(strip $(VERSION))" ""
- override VERSION = $(shell git describe --always --tags --dirty)
-@@ -45,6 +46,7 @@ endif
+ override VERSION = $(shell git describe --always --tags --dirty)
+@@ -52,7 +53,7 @@ GO_BUILD_TAGS_windows = "release"
GO_LDFLAGS = -X $(VERSION_PACKAGE).version=$(VERSION)
GO_LDFLAGS += -X $(VERSION_PACKAGE).buildDate=$(shell date +'%Y-%m-%dT%H:%M:%SZ')
GO_LDFLAGS += -X $(VERSION_PACKAGE).gitCommit=$(COMMIT)
+-GO_LDFLAGS += -X $(VERSION_PACKAGE).gitTreeState=$(if $(shell git status --porcelain),dirty,clean)
+GO_LDFLAGS += -X $(VERSION_PACKAGE).gitTreeState=$(TREE_STATE)
GO_LDFLAGS += -s -w
- GO_BUILD_TAGS_linux = osusergo netgo static_build release
+ GO_LDFLAGS_windows =" $(GO_LDFLAGS) -extldflags \"$(LDFLAGS_windows)\""