summarylogtreecommitdiffstats
path: root/build_python.sh
diff options
context:
space:
mode:
authorJingbei Li2019-06-25 16:07:22 +0800
committerJingbei Li2019-06-25 16:58:08 +0800
commit7f638154d2cd4e426e11c92d826817bb4b50715e (patch)
treee8dab27bfeb53c7581e2dc1282cc976ded9b6f82 /build_python.sh
parent0d3c8b8b01bc2f25ee7ddd7b4e190242f139b244 (diff)
downloadaur-7f638154d2cd4e426e11c92d826817bb4b50715e.tar.gz
build against gcc8's headers
Diffstat (limited to 'build_python.sh')
-rw-r--r--build_python.sh23
1 files changed, 0 insertions, 23 deletions
diff --git a/build_python.sh b/build_python.sh
deleted file mode 100644
index d1f26ad9e682..000000000000
--- a/build_python.sh
+++ /dev/null
@@ -1,23 +0,0 @@
-#!/bin/sh
-# This shell script repeats building scipy with and without an environment variable needed since newest versions of
-# the intel C compiler lack support for float128 while glibc expects this.
-# The set environment variable, however, precludes compiling C++ code
-# So, if the build process fails, it is re-run without the environment variable und continues until failing again etc.
-set +e
-build="$1 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem"
-
-method1() {
- echo Retry: $retry Method: 1
- $build
-}
-
-method2() {
- echo Retry: $retry Method: 2
- __INTEL_PRE_CFLAGS="$__INTEL_PRE_CFLAGS -D_Float32=float -D_Float64=double -D_Float128=\"long double\" -D_Float32x=_Float64 -D_Float64x=_Float128" $build
-}
-
-# It will end at 'Retry: 5 Method: 2' for scipy 1.1.0 and intel-parallel-studio-xe 2018.3.222
-for retry in $(seq 10); do
- method1 && break
- method2 && break
-done