summarylogtreecommitdiffstats
path: root/build_python2.sh
diff options
context:
space:
mode:
authorSimone Riva2018-07-06 19:45:11 +0200
committerSimone Riva2018-07-06 19:45:11 +0200
commitb04eb46ea39d9afc9c7c6993d9a598c2f60dfe69 (patch)
tree2b2b494cc666def3c9df49e7c8440f219ea1aa60 /build_python2.sh
parentd532a6fa84ed5582559d5aae0fba4f9051579113 (diff)
downloadaur-b04eb46ea39d9afc9c7c6993d9a598c2f60dfe69.tar.gz
1.1.0
Diffstat (limited to 'build_python2.sh')
-rw-r--r--build_python2.sh39
1 files changed, 0 insertions, 39 deletions
diff --git a/build_python2.sh b/build_python2.sh
deleted file mode 100644
index 18cd56c87a1d..000000000000
--- a/build_python2.sh
+++ /dev/null
@@ -1,39 +0,0 @@
-#!/bin/sh
-# This shell script repeats building scipy with and without an environment variable needed since newest versions of
-# the intel C compiler lack support for float128 while glibc expects this.
-# The set environment variable, however, precludes compiling C++ code
-# So, if the build process fails, it is re-run without the environment variable und continues until failing again etc.
-{
- # try the following code
- python2 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem
-} || {
- # if that fails add environment variable
- __INTEL_PRE_CFLAGS=" -D_Float128=__float128" python2 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem
-} || {
- #if that fails try again without
- python2 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem
-} || {
- # if that fails add environment variable
- __INTEL_PRE_CFLAGS=" -D_Float128=__float128" python2 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem
-} || {
- #if that fails try again without
- python2 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem
-} || {
- # if that fails add environment variable
- __INTEL_PRE_CFLAGS=" -D_Float128=__float128" python2 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem
-} || {
- #if that fails try again without
- python2 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem
-} || {
- # if that fails add environment variable
- __INTEL_PRE_CFLAGS=" -D_Float128=__float128" python2 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem
-} || {
- #if that fails try again without
- python2 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem
-} || {
- # if that fails add environment variable
- __INTEL_PRE_CFLAGS=" -D_Float128=__float128" python2 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem
-} || {
- #if that fails try again without
- python2 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem
-}