summarylogtreecommitdiffstats
path: root/cc.deb.PKGBUILD
diff options
context:
space:
mode:
authorMoses Narrow2022-04-14 16:35:32 -0500
committerMoses Narrow2022-04-14 16:35:32 -0500
commit22943dbc354611ad6575c5a9765063455f5dbf1c (patch)
tree2f4f5671f16f8fd7a601b6d32068bb200c3ff027 /cc.deb.PKGBUILD
parentb9f6ccc52ef20b6d1974afc8ee6560eead4c2ab7 (diff)
downloadaur-22943dbc354611ad6575c5a9765063455f5dbf1c.tar.gz
update desktop systray app integration
Diffstat (limited to 'cc.deb.PKGBUILD')
-rw-r--r--cc.deb.PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/cc.deb.PKGBUILD b/cc.deb.PKGBUILD
index 5eace8559d84..fe0d6d9dc48e 100644
--- a/cc.deb.PKGBUILD
+++ b/cc.deb.PKGBUILD
@@ -5,8 +5,8 @@ _githuborg=${_projectname}
pkgdesc="Skywire Mainnet Node implementation. Debian package; cross-compile."
_pkggopath="github.com/${_githuborg}/${_pkgname}"
pkgver=0.6.0
-pkgrel=2
-#pkgrel=2
+pkgrel=3
+#pkgrel=3
arch=( 'i686' 'x86_64' 'aarch64' 'armv8' 'armv7' 'armv7l' 'armv7h' 'armv6h' 'armhf' 'armel' 'arm' )
url="https://${_pkggopath}"
license=()
@@ -162,6 +162,11 @@ install -Dm644 ${srcdir}/${_scripts}/systemd/${_pkgname}.service ${_pkgdir}/${_s
install -Dm644 ${srcdir}/${_scripts}/systemd/${_pkgname}-autoconfig.service ${_pkgdir}/${_systemddir}/${_pkgname}-autoconfig.service
install -Dm644 ${srcdir}/${_scripts}/systemd/${_pkgname}-autoconfig-remote.service ${_pkgdir}/${_systemddir}/${_pkgname}-autoconfig-remote.service
+_msg2 'installing desktop files and icon'
+install -Dm644 ${srcdir}/${_scripts}/desktop/com.skywire.Skywire.desktop ${_pkgdir}/usr/share/applications/com.skywire.Skywire.desktop
+install -Dm644 ${srcdir}/${_scripts}/desktop/skywire.png ${_pkgdir}/${_skydir}/icon.png
+ln -rTsf ${_pkgdir}/${_skydir}/icon.png ${_pkgdir}/usr/share/icons/hicolor/48x48/apps/skywire.png
+
_msg2 'installing control file and install scripts'
install -Dm755 ${srcdir}/${_pkgarch}.control ${_pkgdir}/DEBIAN/control
#install -Dm755 ${srcdir}/${_scripts}/preinst.sh ${_pkgdir}/DEBIAN/preinst