summarylogtreecommitdiffstats
path: root/ccache.sh.in
diff options
context:
space:
mode:
authorQue Quotion2018-11-06 01:10:43 +0900
committerQue Quotion2018-11-06 01:29:31 +0900
commitfc511b6f4591738fd17711ae144aa620d8d7919e (patch)
treebc7af83b1dee9972c020928c411d33e528412e80 /ccache.sh.in
parent121dacbfc1c5742ce8203dfea425f990448a881d (diff)
downloadaur-fc511b6f4591738fd17711ae144aa620d8d7919e.tar.gz
Updated for pacman with extendible buildenv
Diffstat (limited to 'ccache.sh.in')
-rw-r--r--ccache.sh.in46
1 files changed, 0 insertions, 46 deletions
diff --git a/ccache.sh.in b/ccache.sh.in
deleted file mode 100644
index 8d9e0b5e0dbb..000000000000
--- a/ccache.sh.in
+++ /dev/null
@@ -1,46 +0,0 @@
-#!/usr/bin/bash
-#
-# ccache.sh - Cache compiliations and recycle them to save time on repititions
-#
-# Copyright (c) 2008-2016 Pacman Development Team <pacman-dev@archlinux.org>
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program. If not, see <http://www.gnu.org/licenses/>.
-#
-
-[[ -n "$LIBMAKEPKG_CCACHE_SH" ]] && return
-LIBMAKEPKG_CCACHE_SH=1
-
-LIBRARY=${LIBRARY:-'@libmakepkgdir@'}
-
-source "$LIBRARY/util/message.sh"
-source "$LIBRARY/util/option.sh"
-
-build_options+=('ccache')
-
-local ccache=0
-
-ccache() {
-
- # use ccache if it is requested (check buildenv and PKGBUILD opts)
- if check_buildoption "ccache" "y"; then
- if ! type -p ccache >/dev/null; then
- error "$(gettext "Cannot find the %s binary required for compiler cache usage.")" "ccache"
- return 1
- fi
- if [ -d /usr/lib/ccache/bin ]; then
- export PATH="/usr/lib/ccache/bin:$PATH"
- ccache=1
- fi
- fi
-}