summarylogtreecommitdiffstats
path: root/clang-doc-build-as-clang_tool.patch
diff options
context:
space:
mode:
authorFelix Schindler2020-09-23 09:13:38 +0000
committerFelix Schindler2020-09-23 13:39:48 +0000
commit66f28ef57783edc9807b6a75d08c9ebbe53a4d03 (patch)
tree98ab81ca9696e765ef2fe4be8db374b24cebb0e3 /clang-doc-build-as-clang_tool.patch
downloadaur-clang8.tar.gz
[8.0.1-1]
Initialized and adapted from https://github.com/archlinux/svntogit-packages/raw/d8ffa1f43e5b1d12d1a1980b34bb668c4075892f/trunk/
Diffstat (limited to 'clang-doc-build-as-clang_tool.patch')
-rw-r--r--clang-doc-build-as-clang_tool.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/clang-doc-build-as-clang_tool.patch b/clang-doc-build-as-clang_tool.patch
new file mode 100644
index 000000000000..29694ff07e0a
--- /dev/null
+++ b/clang-doc-build-as-clang_tool.patch
@@ -0,0 +1,26 @@
+From 45e92fcf45def2b59c06b6407c73b798eaa321ae Mon Sep 17 00:00:00 2001
+From: Julie Hockett <juliehockett@google.com>
+Date: Fri, 29 Mar 2019 16:56:36 +0000
+Subject: [PATCH] [clang-doc] Build as clang_tool
+
+Instead of as clang_executable.
+
+Differential Revision: https://reviews.llvm.org/D59974
+
+git-svn-id: https://llvm.org/svn/llvm-project/clang-tools-extra/trunk@357274 91177308-0d34-0410-b5e6-96231b3b80d8
+---
+ clang-doc/tool/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/clang-doc/tool/CMakeLists.txt b/clang-doc/tool/CMakeLists.txt
+index d7f28cf681..35f99ea08e 100644
+--- a/clang-doc/tool/CMakeLists.txt
++++ b/clang-doc/tool/CMakeLists.txt
+@@ -1,6 +1,6 @@
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/..)
+
+-add_clang_executable(clang-doc
++add_clang_tool(clang-doc
+ ClangDocMain.cpp
+ )
+