summarylogtreecommitdiffstats
path: root/clang-profile.patch
diff options
context:
space:
mode:
authorMatt Parnell2019-06-30 22:25:13 -0500
committerMatt Parnell2019-06-30 22:25:13 -0500
commitf198206a04438900ef3a30ea351549635dfef96e (patch)
tree2861081f69c045a05a7a7c22f4861ef57159a3d1 /clang-profile.patch
parent3222a7ff4ad6fcd17c3da45152efdf66064a60ca (diff)
downloadaur-f198206a04438900ef3a30ea351549635dfef96e.tar.gz
remove unused patches
Diffstat (limited to 'clang-profile.patch')
-rw-r--r--clang-profile.patch184
1 files changed, 0 insertions, 184 deletions
diff --git a/clang-profile.patch b/clang-profile.patch
deleted file mode 100644
index caeb402561b6..000000000000
--- a/clang-profile.patch
+++ /dev/null
@@ -1,184 +0,0 @@
-diff --git a/build/pgo/profileserver.py b/build/pgo/profileserver.py
-index 3e5a870c33d3..140f6f9c7de3 100644
---- a/build/pgo/profileserver.py
-+++ b/build/pgo/profileserver.py
-@@ -37,7 +37,7 @@ if __name__ == '__main__':
-
- #TODO: mozfile.TemporaryDirectory
- profilePath = tempfile.mkdtemp()
-- try:
-+ try:
- #TODO: refactor this into mozprofile
- prefpath = os.path.join(build.topsrcdir, "testing", "profiles", "prefs_general.js")
- prefs = {}
-@@ -53,6 +53,7 @@ if __name__ == '__main__':
- locations=locations)
-
- env = os.environ.copy()
-+ env["LLVM_PROFILE_FILE"] = "runpid-%p.profraw" # clang can hit naming conflicts if we don't do this
- env["MOZ_CRASHREPORTER_NO_REPORT"] = "1"
- env["XPCOM_DEBUG_BREAK"] = "warn"
-
-@@ -72,7 +73,7 @@ if __name__ == '__main__':
- binary=build.get_binary_path(where="staged-package"),
- cmdargs=['javascript:Quitter.quit()'],
- env=env)
-- runner.start()
-+ runner.start(outputTimeout=60) # allow up to 60 seconds to start and create a profile
- runner.wait()
-
- jarlog = os.getenv("JARLOG_FILE")
-@@ -88,5 +89,15 @@ if __name__ == '__main__':
- runner.start(debug_args=debug_args, interactive=interactive)
- runner.wait()
- httpd.stop()
-+
-+ # this is hacky but should build our profdata for use, at least for the main browser...not the other stuff
-+ # i'm not super up on the current state of the mozilla build system so for other profraws and other profdata
-+ # generated, and for this, it'd be nice to properly get an llvm-profdata search in configure
-+ # and properly add it to the flow... just proof of concept for me - halp please!
-+ # also, wouldn't it make sense to add an argument to copy an actual user profile,
-+ # and start up on the blank tab page when possible for a more real-world loadup? todo?
-+ # Matt Parnell/ilikenwf <parwok@gmail.com>
-+ os.chdir(build.topobjdir)
-+ os.system("llvm-profdata merge -output=/tmp/default.profdata *.profraw &> /dev/null")
- finally:
- shutil.rmtree(profilePath)
-diff --git a/js/src/old-configure.in b/js/src/old-configure.in
-index 70b6a7dc7af9..832010150cab 100644
---- a/js/src/old-configure.in
-+++ b/js/src/old-configure.in
-@@ -1823,13 +1823,18 @@ else
- fi
-
- dnl ========================================================
--dnl Profile guided optimization (gcc checks)
-+dnl Profile guided optimization (gcc/clang checks)
- dnl ========================================================
- dnl Test for profiling options
--dnl Under gcc 3.4+, use -fprofile-generate/-fprofile-use
-+dnl Under gcc 3.4+ and clang use -fprofile-generate/-fprofile-use
-
- _SAVE_CFLAGS="$CFLAGS"
--CFLAGS="$CFLAGS -fprofile-generate -fprofile-correction"
-+
-+if test -n "${CLANG_CC}"; then
-+ CFLAGS="$CFLAGS -fprofile-generate"
-+else
-+ CFLAGS="$CFLAGS -fprofile-generate -fprofile-correction"
-+fi
-
- AC_MSG_CHECKING([whether C compiler supports -fprofile-generate])
- AC_TRY_COMPILE([], [return 0;],
-@@ -1838,11 +1843,15 @@ AC_TRY_COMPILE([], [return 0;],
- AC_MSG_RESULT([$result])
-
- if test $result = "yes"; then
-- PROFILE_GEN_LDFLAGS="-fprofile-generate"
-- PROFILE_USE_CFLAGS="-fprofile-use -fprofile-correction -Wcoverage-mismatch"
-- PROFILE_USE_LDFLAGS="-fprofile-use"
-+ if test -n "${CLANG_CC}"; then
-+ PROFILE_GEN_CFLAGS="-fprofile-generate"
-+ PROFILE_USE_CFLAGS='-fprofile-instr-use=/tmp/default.profdata'
-+ else
-+ PROFILE_GEN_LDFLAGS="-fprofile-generate"
-+ PROFILE_USE_CFLAGS="-fprofile-use -fprofile-correction -Wcoverage-mismatch"
-+ PROFILE_USE_LDFLAGS="-fprofile-use"
-+ fi
- fi
--
- CFLAGS="$_SAVE_CFLAGS"
-
- AC_SUBST(PROFILE_GEN_CFLAGS)
-diff --git a/nsprpub/configure.in b/nsprpub/configure.in
-index 22b4e72245d1..1f565e79d300 100644
---- a/nsprpub/configure.in
-+++ b/nsprpub/configure.in
-@@ -750,13 +750,18 @@ else
- fi
-
- dnl ========================================================
--dnl Profile guided optimization
-+dnl Profile guided optimization (gcc/clang checks)
- dnl ========================================================
- dnl Test for profiling options
--dnl Under gcc 3.4+, use -fprofile-generate/-fprofile-use
-+dnl Under gcc 3.4+ and clang use -fprofile-generate/-fprofile-use
-
- _SAVE_CFLAGS="$CFLAGS"
--CFLAGS="$CFLAGS -fprofile-generate -fprofile-correction"
-+
-+if test -n "${CLANG_CC}"; then
-+ CFLAGS="$CFLAGS -fprofile-generate"
-+else
-+ CFLAGS="$CFLAGS -fprofile-generate -fprofile-correction"
-+fi
-
- AC_MSG_CHECKING([whether C compiler supports -fprofile-generate])
- AC_TRY_COMPILE([], [return 0;],
-@@ -765,11 +770,15 @@ AC_TRY_COMPILE([], [return 0;],
- AC_MSG_RESULT([$result])
-
- if test $result = "yes"; then
-- PROFILE_GEN_LDFLAGS="-fprofile-generate"
-- PROFILE_USE_CFLAGS="-fprofile-use -fprofile-correction -Wcoverage-mismatch"
-- PROFILE_USE_LDFLAGS="-fprofile-use"
-+ if test -n "${CLANG_CC}"; then
-+ PROFILE_GEN_CFLAGS="-fprofile-generate"
-+ PROFILE_USE_CFLAGS='-fprofile-instr-use=/tmp/default.profdata'
-+ else
-+ PROFILE_GEN_LDFLAGS="-fprofile-generate"
-+ PROFILE_USE_CFLAGS="-fprofile-use -fprofile-correction -Wcoverage-mismatch"
-+ PROFILE_USE_LDFLAGS="-fprofile-use"
-+ fi
- fi
--
- CFLAGS="$_SAVE_CFLAGS"
-
- dnl ===============================================================
-diff --git a/old-configure.in b/old-configure.in
-index 662d77aaf99f..1ef312e22e6b 100644
---- a/old-configure.in
-+++ b/old-configure.in
-@@ -4213,13 +4213,18 @@ else
- fi
-
- dnl ========================================================
--dnl Profile guided optimization (gcc checks)
-+dnl Profile guided optimization (gcc/clang checks)
- dnl ========================================================
- dnl Test for profiling options
--dnl Under gcc 3.4+, use -fprofile-generate/-fprofile-use
-+dnl Under gcc 3.4+ and clang use -fprofile-generate/-fprofile-use
-
- _SAVE_CFLAGS="$CFLAGS"
--CFLAGS="$CFLAGS -fprofile-generate -fprofile-correction"
-+
-+if test -n "${CLANG_CC}"; then
-+ CFLAGS="$CFLAGS -fprofile-generate"
-+else
-+ CFLAGS="$CFLAGS -fprofile-generate -fprofile-correction"
-+fi
-
- AC_MSG_CHECKING([whether C compiler supports -fprofile-generate])
- AC_TRY_COMPILE([], [return 0;],
-@@ -4228,11 +4233,15 @@ AC_TRY_COMPILE([], [return 0;],
- AC_MSG_RESULT([$result])
-
- if test $result = "yes"; then
-- PROFILE_GEN_LDFLAGS="-fprofile-generate"
-- PROFILE_USE_CFLAGS="-fprofile-use -fprofile-correction -Wcoverage-mismatch"
-- PROFILE_USE_LDFLAGS="-fprofile-use"
-+ if test -n "${CLANG_CC}"; then
-+ PROFILE_GEN_CFLAGS="-fprofile-generate"
-+ PROFILE_USE_CFLAGS='-fprofile-instr-use=/tmp/default.profdata'
-+ else
-+ PROFILE_GEN_LDFLAGS="-fprofile-generate"
-+ PROFILE_USE_CFLAGS="-fprofile-use -fprofile-correction -Wcoverage-mismatch"
-+ PROFILE_USE_LDFLAGS="-fprofile-use"
-+ fi
- fi
--
- CFLAGS="$_SAVE_CFLAGS"
-
- AC_SUBST(PROFILE_GEN_CFLAGS)