summarylogtreecommitdiffstats
path: root/cmake-install-location.patch
diff options
context:
space:
mode:
authoreinstein952019-11-21 17:27:31 +1300
committereinstein952019-11-21 17:27:31 +1300
commit005029e3b6cba95d5ace56ea88bec0192f8eacf0 (patch)
treed5158609dab0cd30fedfa066f5d3c5e6d739471e /cmake-install-location.patch
downloadaur-005029e3b6cba95d5ace56ea88bec0192f8eacf0.tar.gz
Initial commit
Diffstat (limited to 'cmake-install-location.patch')
-rw-r--r--cmake-install-location.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/cmake-install-location.patch b/cmake-install-location.patch
new file mode 100644
index 000000000000..ffae36cf845f
--- /dev/null
+++ b/cmake-install-location.patch
@@ -0,0 +1,13 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index fd12cb7..5e74fe7 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -32,7 +32,7 @@ if (WIN32)
+ endif()
+
+ if(UNIX AND NOT APPLE)
+- install(TARGETS gbe_plus DESTINATION /usr/local/bin)
++ install(TARGETS gbe_plus DESTINATION bin)
+ install(FILES gbe.ini DESTINATION ${USER_HOME}/.gbe_plus/)
+ install(DIRECTORY data DESTINATION ${USER_HOME}/.gbe_plus/)
+ install(CODE "execute_process(COMMAND chown -R ${USER}:${USER} ${USER_HOME}/.gbe_plus)")