summarylogtreecommitdiffstats
path: root/cmake.patch
diff options
context:
space:
mode:
authorjerry732042020-10-23 03:35:11 +0800
committerjerry732042020-10-23 03:35:11 +0800
commitead6594709efa9481f6e6c1feacc7a6f8cd56e75 (patch)
treefb43f6c9ef09977b9d0be471aab7938acbc4e961 /cmake.patch
parentbf54c3a4672e2b1fa70021cdde36ee48a4dbde04 (diff)
downloadaur-ead6594709efa9481f6e6c1feacc7a6f8cd56e75.tar.gz
Bump to 3.1.3-1
Diffstat (limited to 'cmake.patch')
-rw-r--r--cmake.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/cmake.patch b/cmake.patch
new file mode 100644
index 000000000000..80f566236f4c
--- /dev/null
+++ b/cmake.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6b00d03..c04c165 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -70,7 +70,7 @@ if (NOT Python3_NOT_FOUND AND NOT Numpy_NOT_FOUND AND PYTHONLIBS_FOUND)
+ # TODO deal with both python2/3
+ execute_process(COMMAND python3 ${CMAKE_SOURCE_DIR}/python_build_flags.py OUTPUT_VARIABLE PY_OUT)
+ set(PY_VARS CFLAGS LDFLAGS LINKER EXT_SUFFIX)
+-cmake_parse_arguments(PY "" "${PY_VARS}" "" ${PY_OUT})
++cmake_parse_arguments(PY "" ${PY_VARS} "" ${PY_OUT})
+ separate_arguments(PY_CFLAGS)
+ separate_arguments(PY_LDFLAGS)
+