summarylogtreecommitdiffstats
path: root/cmake_boost.patch
diff options
context:
space:
mode:
authorCubeTheThird2020-03-08 20:36:15 -0400
committerCubeTheThird2020-03-08 20:36:15 -0400
commitad9cdc54b55edf4294a230c0b557a06f48333ead (patch)
tree31efa15df1d38029ce766cb4293c36a1e94114f0 /cmake_boost.patch
parent4ddbab2cf38bcd76ab5e510d05756a1ec7fb73ac (diff)
downloadaur-ad9cdc54b55edf4294a230c0b557a06f48333ead.tar.gz
Added patch for cmake boost.
Diffstat (limited to 'cmake_boost.patch')
-rw-r--r--cmake_boost.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/cmake_boost.patch b/cmake_boost.patch
new file mode 100644
index 000000000000..4ddad6acf001
--- /dev/null
+++ b/cmake_boost.patch
@@ -0,0 +1,13 @@
+diff --git CMakeLists.txt CMakeLists.txt
+index 10969c2..dd28028 100644
+--- e4rat-lite/CMakeLists.txt
++++ e4rat-lite/CMakeLists.txt
+@@ -20,7 +20,7 @@ IF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
+ ENDIF(CMAKE_INSTALL_PREFIX_INITIALIZED_TO_DEFAULT)
+
+ set(Boost_USE_STATIC_LIBS OFF)
+-set(Boost_USE_MULTITHREADED OFF)
++set(Boost_USE_MULTITHREADED ON)
+ find_package(Boost 1.41 COMPONENTS system filesystem regex REQUIRED)
+ set(${PROJECT_NAME}_LIBRARIES ${${PROJECT_NAME}_LIBRARIES}
+ ${Boost_LIBRARIES})