aboutsummarylogtreecommitdiffstats
path: root/compile.patch
diff options
context:
space:
mode:
authorSoc Virnyl S. Estela2021-04-08 13:45:55 +0800
committerSoc Virnyl S. Estela2021-04-08 13:45:55 +0800
commit0020e92e2c5a558b12a7248f7835a87a4b092822 (patch)
treec4e66bb61c3786a74927d319c5c9a5297af6fc6b /compile.patch
parentdc323b9d1f91f8ff39cb831d91fe0e6befef6842 (diff)
downloadaur-0020e92e2c5a558b12a7248f7835a87a4b092822.tar.gz
Update PKGBUILD
Diffstat (limited to 'compile.patch')
-rw-r--r--compile.patch45
1 files changed, 15 insertions, 30 deletions
diff --git a/compile.patch b/compile.patch
index a04af1133c72..f9e96bdee528 100644
--- a/compile.patch
+++ b/compile.patch
@@ -1,41 +1,26 @@
---- a/compile.py 2021-04-07 08:29:14.860019874 +0800
-+++ b/compile.py 2021-04-07 08:36:43.660024924 +0800
-@@ -1,4 +1,4 @@
--#!/usr/bin/python2
-+#!/usr/bin/env python
-
- import subprocess
- import sys
-@@ -103,19 +103,19 @@
+--- a/compile.py 2021-04-07 07:31:51.000000000 +0800
++++ b/compile.py 2021-04-08 13:02:51.590097363 +0800
+@@ -103,17 +103,17 @@
# Now proceed with the installation
-if not os.path.exists(pjoin(pythia8_path,'share','Pythia8','examples','Makefile.inc')):
-- print( "Error in MG5aMC_PY8_interface installer. Could not find file:\n %s"%\
++if not os.path.exists(pjoin(pythia8_path,'share','pythia8','examples','Makefile.inc')):
+ print( "Error in MG5aMC_PY8_interface installer. Could not find file:\n %s"%\
- pjoin(pythia8_path,'share','Pythia8','examples','Makefile.inc'))
-- sys.exit(error_exit_code)
++ pjoin(pythia8_path,'share','pythia8','examples','Makefile.inc'))
+ sys.exit(error_exit_code)
-shutil.copy(pjoin(pythia8_path,'share','Pythia8','examples','Makefile.inc'),
-- pjoin(local_path,'Makefile.inc'))
++shutil.copy(pjoin(pythia8_path,'share','pythia8','examples','Makefile.inc'),
+ pjoin(local_path,'Makefile.inc'))
-if not os.path.exists(pjoin(pythia8_path,'share','Pythia8','examples','Makefile')):
-- print( "Error in MG5aMC_PY8_interface installer. Could not find file:\n %s"%\
++if not os.path.exists(pjoin(pythia8_path,'share','pythia8','examples','Makefile')):
+ print( "Error in MG5aMC_PY8_interface installer. Could not find file:\n %s"%\
- pjoin(pythia8_path,'share','Pythia8','examples','Makefile'))
-- sys.exit(error_exit_code)
++ pjoin(pythia8_path,'share','pythia8','examples','Makefile'))
+ sys.exit(error_exit_code)
-shutil.copy(pjoin(pythia8_path,'share','Pythia8','examples','Makefile'),
-- pjoin(local_path,'Makefile'))
--
-+if not os.path.exists(pjoin(pythia8_path,'share','pythia8','examples','Makefile.inc')):
-+ print "Error in MG5aMC_PY8_interface installer. Could not find file:\n %s"%\
-+ pjoin(pythia8_path,'share','pythia8','examples','Makefile.inc')
-+ sys.exit(error_exit_code)
-+shutil.copy(pjoin(pythia8_path,'share','pythia8','examples','Makefile.inc'),
-+ pjoin(local_path,'Makefile.inc'))
-+if not os.path.exists(pjoin(pythia8_path,'share','pythia8','examples','Makefile')):
-+ print "Error in MG5aMC_PY8_interface installer. Could not find file:\n %s"%\
-+ pjoin(pythia8_path,'share','pythia8','examples','Makefile')
-+ sys.exit(error_exit_code)
+shutil.copy(pjoin(pythia8_path,'share','pythia8','examples','Makefile'),
-+ pjoin(local_path,'Makefile'))
-+
+ pjoin(local_path,'Makefile'))
+
if _use_original_PY8_makefile:
- shutil.move(pjoin(local_path,'MG5aMC_PY8_interface.cc'),pjoin(local_path,'main89.cc'))
- p = subprocess.Popen(['make','main89'], stdout=subprocess.PIPE,