summarylogtreecommitdiffstats
path: root/compile.sh
diff options
context:
space:
mode:
authorUwe Hermann2019-06-30 11:59:15 +0000
committerUwe Hermann2019-06-30 11:59:15 +0000
commit5a9723c0144c5d5b6353cd8bb9de1513cbf34377 (patch)
treec0b01d45a912b86ddf72fc61b34f92f14b6ec951 /compile.sh
parent6eaf22a09235c559dbee8c48501c25a932d560ff (diff)
downloadaur-5a9723c0144c5d5b6353cd8bb9de1513cbf34377.tar.gz
* MOD: updated PKGBUILD for easier installation
* MOD: updated compile.sh to not include files not present anymore Signed-off-by: Uwe Hermann <dev@uleenucks.de>
Diffstat (limited to 'compile.sh')
-rwxr-xr-xcompile.sh6
1 files changed, 2 insertions, 4 deletions
diff --git a/compile.sh b/compile.sh
index 29f02813921c..407e7e1f21f3 100755
--- a/compile.sh
+++ b/compile.sh
@@ -1,10 +1,8 @@
#!/bin/sh
-rm -rf src/
+[[ -d "src" ]] && rm -rf src/
[[ -f "config.def.h" ]] && rm config.def.h
[[ "$(hostname)" == "uh-x200s" ]] && cp config.def.h.x200s config.def.h
[[ "$(hostname)" == "uh-x230" ]] && cp config.def.h.x230 config.def.h
-[[ "$(hostname)" == "uh-lin" ]] && cp config.def.h.work config.def.h
updpkgsums
makepkg -fi --noconfirm
-rm -rf dwm/
-rm config.def.h
+[[ -d "dwm" ]] && rm -rf dwm/