summarylogtreecommitdiffstats
path: root/compiler.patch
diff options
context:
space:
mode:
authorOtakar Jašek2020-08-30 16:54:06 +0200
committerOtakar Jašek2020-08-30 16:54:06 +0200
commitade8941ad8eecb063098ee177c049a492b320721 (patch)
tree5b0df01eb9c52b78cce80f0b9389f0b226f065f3 /compiler.patch
parentd05dd99061bca042940b8af8992254f6c9889cc2 (diff)
downloadaur-ade8941ad8eecb063098ee177c049a492b320721.tar.gz
Redone package for cmake
Diffstat (limited to 'compiler.patch')
-rw-r--r--compiler.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/compiler.patch b/compiler.patch
new file mode 100644
index 000000000000..1c6cdf2ac663
--- /dev/null
+++ b/compiler.patch
@@ -0,0 +1,12 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 29b73d8..f8899a0 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -22,7 +22,6 @@ option(FAISS_ENABLE_GPU "Enable support for GPU indexes." ON)
+ option(FAISS_ENABLE_PYTHON "Build Python extension." ON)
+
+ if(FAISS_ENABLE_GPU)
+- set(CMAKE_CUDA_HOST_COMPILER ${CMAKE_CXX_COMPILER})
+ enable_language(CUDA)
+ endif()
+