aboutsummarylogtreecommitdiffstats
path: root/config.default.h
diff options
context:
space:
mode:
authorAnselm R. Garbe2007-08-11 12:11:50 +0200
committerAnselm R. Garbe2007-08-11 12:11:50 +0200
commitf4ecc2c732d07629ba1d916607ec892bef6b294f (patch)
tree4cd055a398d3a98c441a6d50f4fbf4a205c78d04 /config.default.h
parentab3bdd61d19d8a2988a83963bd261455f3756fb1 (diff)
downloadaur-f4ecc2c732d07629ba1d916607ec892bef6b294f.tar.gz
separated layout-specific stuff into separate .h and .c files which are included in config.h resp. config.mk - this allows writing layouts for dwm without any need to patch existing code
Diffstat (limited to 'config.default.h')
-rw-r--r--config.default.h7
1 files changed, 4 insertions, 3 deletions
diff --git a/config.default.h b/config.default.h
index ec32e9dafb54..1f0fe8cbcbd6 100644
--- a/config.default.h
+++ b/config.default.h
@@ -25,7 +25,8 @@ static Rule rule[] = { \
};
/* layout(s) */
-void tile(const char *arg); /* arranges all windows tiled */
+#include "tile.h"
+#include "float.h"
#define LAYOUTS \
static Layout layout[] = { \
/* symbol function */ \
@@ -44,10 +45,10 @@ static Key key[] = { \
{ MODKEY, XK_p, spawn, "exe=`dmenu_path | dmenu` && exec $exe" }, \
{ MODKEY, XK_space, setlayout, NULL }, \
{ MODKEY, XK_b, togglebar, NULL }, \
- { MODKEY, XK_h, tile, "-0.05" }, \
{ MODKEY, XK_j, focusclient, "1" }, \
{ MODKEY, XK_k, focusclient, "-1" }, \
- { MODKEY, XK_l, tile, "0.05" }, \
+ { MODKEY, XK_h, incmaster, "-0.05" }, \
+ { MODKEY, XK_l, incmaster, "0.05" }, \
{ MODKEY, XK_m, togglemax, NULL }, \
{ MODKEY, XK_Return, zoom, NULL }, \
{ MODKEY|ShiftMask, XK_space, togglefloating, NULL }, \