aboutsummarylogtreecommitdiffstats
path: root/config.mk
diff options
context:
space:
mode:
authorAnselm R Garbe2008-05-19 15:05:46 +0100
committerAnselm R Garbe2008-05-19 15:05:46 +0100
commit121a1708be3493e146042970bd21741789d84908 (patch)
treec4ee5cfa3d61328b627e8740975e77ad87a48dbd /config.mk
parent6328e3d5aeee2d5308ca1a967289da25c78186ea (diff)
downloadaur-121a1708be3493e146042970bd21741789d84908.tar.gz
make it easier for the user, if Xinerama support is given, always use the screen 0 as window area/bar area, everything else can be used for floating clients
Diffstat (limited to 'config.mk')
-rw-r--r--config.mk11
1 files changed, 8 insertions, 3 deletions
diff --git a/config.mk b/config.mk
index b18ad3308073..e9c956e76e7a 100644
--- a/config.mk
+++ b/config.mk
@@ -10,14 +10,19 @@ MANPREFIX = ${PREFIX}/share/man
X11INC = /usr/X11R6/include
X11LIB = /usr/X11R6/lib
+# Xinerama, uncomment if you don't want it
+XINERAMALIBS = -L${X11LIB} -lXinerama
+XINERAMAFLAGS = -DXINERAMA
+
# includes and libs
INCS = -I. -I/usr/include -I${X11INC}
-LIBS = -L/usr/lib -lc -L${X11LIB} -lX11
+LIBS = -L/usr/lib -lc -L${X11LIB} -lX11 ${XINERAMALIBS}
# flags
-CFLAGS = -Os ${INCS} -DVERSION=\"${VERSION}\"
+CPPFLAGS = -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
+CFLAGS = -Os ${INCS} ${CPPFLAGS}
LDFLAGS = -s ${LIBS}
-#CFLAGS = -g -std=c99 -pedantic -Wall -O2 ${INCS} -DVERSION=\"${VERSION}\"
+#CFLAGS = -g -std=c99 -pedantic -Wall -O2 ${INCS} ${CPPFLAGS}
#LDFLAGS = -g ${LIBS}
# Solaris